aboutsummaryrefslogtreecommitdiffstats
path: root/testing/chromium/APKBUILD
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-11-24 13:19:01 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2011-11-24 13:19:26 -0600
commite3172f521768af3d349a22889229a0e9669de9c6 (patch)
tree17afc461941124d9c1721e009ac6f204cdf5daca /testing/chromium/APKBUILD
parent228431404d99b59b6d67e52d47fa88f3b8cdccb0 (diff)
downloadaports-e3172f521768af3d349a22889229a0e9669de9c6.tar.bz2
aports-e3172f521768af3d349a22889229a0e9669de9c6.tar.xz
testing/chromium: it builds (no promises other than that though)
Diffstat (limited to 'testing/chromium/APKBUILD')
-rw-r--r--testing/chromium/APKBUILD77
1 files changed, 55 insertions, 22 deletions
diff --git a/testing/chromium/APKBUILD b/testing/chromium/APKBUILD
index 2adaf905fa..87759facdf 100644
--- a/testing/chromium/APKBUILD
+++ b/testing/chromium/APKBUILD
@@ -5,31 +5,39 @@ pkgver=17.0.942.0
pkgrel=0
pkgdesc="chromium web browser"
url="http://www.chromium.org/"
-arch=""
-#arch="x86 x86_64"
+arch="x86 x86_64 arm"
license="BSD"
-depends=
+depends="xdg-utils"
depends_dev="alsa-lib-dev libevent-dev libpng-dev jpeg-dev cairo-dev cups-dev mesa-dev
dbus-glib-dev gtk+-dev libxml2-dev freetype-dev
libxslt-dev libxtst-dev icu-dev flac-dev speex-dev
hunspell-dev libxinerama-dev ffmpeg-dev nss-dev
libwebp-dev v8-dev bzip2-dev libevent-dev libvpx-dev
- sqlite-dev"
-makedepends="$depends_dev xdg-utils yasm gperf elfutils bison flex"
+ sqlite-dev libelf-dev"
+makedepends="$depends_dev xdg-utils yasm gperf bison flex perl python"
install=""
-subpackages="$pkgname-dev $pkgname-doc"
-source="http://build.chromium.org/official/chromium-$pkgver.tar.bz2
+subpackages="$pkgname-doc"
+source="http://gsdview.appspot.com/chromium-browser-official/chromium-$pkgver.tar.bz2
chromium-c99math.patch
chromium-futimens.patch
- chromium-uclibc-resolv.patch
chromium-dlfcn.patch
chromium-yasm.patch
chromium-no-mit-screensaver.patch
- chromium-tcmalloc.patch
- chromium-no-sbrk.patch
- chromium-stdstring.patch"
+ chromium-uclibc-resolv.patch
+ chromium-breakpad.patch
+ chromium-webrtc.patch
+ chromium-malloc.patch"
_builddir="$srcdir"/chromium-$pkgver
+
+CHROMIUM_HOME="/usr/lib/${pkgname}"
+CHROMIUM_IMAGE="${_builddir}/out/Release"
+
+# ugly hack to deal with google shipping weird tarballs
+unpack() {
+ default_unpack || return 0
+}
+
prepare() {
local i
cd "$_builddir"
@@ -101,8 +109,9 @@ build() {
werror= \
disable_sse2=1 \
no_strict_aliasing=1 \
- linux_sandbox_path=/usr/lib/${pkgname}/chromium-sandbox \
- linux_sandbox_chrome_path=/usr/lib/${pkgname}/chromium \
+ linux_sandbox_path=${CHROMIUM_HOME}/chromium-sandbox \
+ linux_sandbox_chrome_path=${CHROMIUM_HOME}/chromium \
+ linux_use_tcmalloc=0 \
release_extra_cflags='${CFLAGS}' \
proprietary_codecs=1 \
use_system_libjpeg=1 \
@@ -112,16 +121,23 @@ build() {
use_system_zlib=1 \
use_system_libpng=1 \
use_system_yasm=1 \
+ use_system_flac=1 \
use_system_libevent=1 \
use_system_icu=1 \
use_system_v8=1 \
use_system_libwebp=1 \
use_system_ffmpeg=1 \
use_system_vpx=1 \
- use_system_ssl=1 \
- use_system_sqlite=1 \
+ use_system_ssl=0 \
+ use_system_sqlite=0 \
+ use_system_speex=1 \
+ use_system_xdg_utils=1 \
+ use_cups=1 \
use_gconf=0 \
use_gnome_keyring=0 \
+ use_kerberos=0 \
+ linux_link_kerberos=0 \
+ disable_nacl=1 \
remoting=0 \
target_arch=${chromium_arch}"
export GYP_DEFINES
@@ -130,20 +146,37 @@ build() {
python build/gyp_chromium -f make --depth=. build/all.gyp
msg "building chrome and chrome_sandbox targets"
- make BUILDTYPE=Release chrome chrome_sandbox || return 1
+ make V=1 BUILDTYPE=Release -j$JOBS chrome chrome_sandbox chromedriver || return 1
}
package() {
cd "$_builddir"
+
+ mkdir -p "$pkgdir"/${CHROMIUM_HOME}
+
+ install -m755 -c "${CHROMIUM_IMAGE}/chrome" "${pkgdir}/${CHROMIUM_HOME}/chrome"
+ install -m755 -c "${CHROMIUM_IMAGE}/chromedriver" "${pkgdir}/${CHROMIUM_HOME}/chromedriver"
+ install -m755 -c "${CHROMIUM_IMAGE}/chrome_sandbox" "${pkgdir}/${CHROMIUM_HOME}/chrome_sandbox"
+ install -m644 -c "${CHROMIUM_IMAGE}/chrome.pak" "${pkgdir}/${CHROMIUM_HOME}/chrome.pak"
+ install -m644 -c "${CHROMIUM_IMAGE}/resources.pak" "${pkgdir}/${CHROMIUM_HOME}/resources.pak"
+
+ mkdir -p "$pkgdir"/usr/share/man/man1
+ install -m644 -c "${CHROMIUM_IMAGE}/chrome.1" "${pkgdir}/usr/share/man/man1/chrome.1"
+ ln -sf "chrome.1" "${pkgdir}/usr/share/man/man1/chrome-browser.1"
+
+ ln -sf "${CHROMIUM_HOME}/chrome" "${pkgdir}/usr/bin/chrome"
+ ln -sf "${CHROMIUM_HOME}/chrome" "${pkgdir}/usr/bin/chrome-browser"
+ ln -sf "${CHROMIUM_HOME}/chrome" "${pkgdir}/usr/bin/chromium"
+ ln -sf "${CHROMIUM_HOME}/chrome" "${pkgdir}/usr/bin/chromium-browser"
}
-md5sums="85d73864cc3b78dab29f8851965fc5fa chromium-13.0.754.0.tar.bz2
+md5sums="5660529559b1845217b679a883160873 chromium-17.0.942.0.tar.bz2
320d611dba59a881a4f178df743c4912 chromium-c99math.patch
1328245f1f21cf3abf54223ed06a70f4 chromium-futimens.patch
-4a391028c9d1b8930fc299b6af0767d8 chromium-uclibc-resolv.patch
768d2ca4daa2db611fd4aeb561701f4e chromium-dlfcn.patch
76cb0975e631d54fb57bd298041cec05 chromium-yasm.patch
-f8c8711a358d43ecbd8e1859aa71cfa0 chromium-no-mit-screensaver.patch
-014dd7f7a9decb1d89c0d72f0258ca96 chromium-tcmalloc.patch
-e6302ae2635dc4d0c75c32e97a4bd3b0 chromium-no-sbrk.patch
-eb05d2763beaa02e20ddeaf51dadf327 chromium-stdstring.patch"
+327850010ae407477083b91a4e04af51 chromium-no-mit-screensaver.patch
+441bcd9fc987e290c610e2f1bbfb75f8 chromium-uclibc-resolv.patch
+f6531589ce894fcd9b6f4917e83cd3aa chromium-breakpad.patch
+6257d567f83ad591360c3de4f9073725 chromium-webrtc.patch
+42f0beecf6a9e4e65c88b5acb77d8a51 chromium-malloc.patch"