aboutsummaryrefslogtreecommitdiffstats
path: root/testing/clapf/clapf.pre-install
diff options
context:
space:
mode:
authorPrzemyslaw Pawelczyk <przemoc@zoho.com>2016-06-17 03:47:30 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2016-06-20 13:35:25 +0000
commit071c1400c272c0f381651a0dc9b181ab0abfc1fc (patch)
tree0a4bfda4a910a0cce3d59bbff34bce1880c0eeea /testing/clapf/clapf.pre-install
parent94e0b0631f3760e6ba47edf9dbb2637a575a8019 (diff)
downloadaports-071c1400c272c0f381651a0dc9b181ab0abfc1fc.tar.bz2
aports-071c1400c272c0f381651a0dc9b181ab0abfc1fc.tar.xz
testing/clapf: Fix a lot of problems.
* APKBUILD: Leverage default_prepare and use builddir (no _). * APKBUILD: Update url and source url. Original tar seems not available anymore and there are no tags in clapf's bitbucket repository, so use commit marked as release of version that was shipped before. * APKBUILD: Introduce some constants for better DRY-ness, reformat package() function, create there a workdir (otherwise clapf won't start) and fix permissions. * APKBUILD: make -j1 is deliberate, as it fails with more jobs, but I am not willing to spend any more time on this package. * ldflags.patch: Set soname (otherwise -dev subpkg will haunt you). * clapf.confd: Make it somewhat usable. TMPDIR seemed useless. * clapf.initd: Rewrite using openrc-run default ssd functions. * clapf.pre-install: Change user and group to clapf. It has not been tested with mta, but at least it starts now if you have virus databases present. Run freshclam if you don't have them yet.
Diffstat (limited to 'testing/clapf/clapf.pre-install')
-rw-r--r--testing/clapf/clapf.pre-install4
1 files changed, 2 insertions, 2 deletions
diff --git a/testing/clapf/clapf.pre-install b/testing/clapf/clapf.pre-install
index 7cbfaad04b..b2207408ad 100644
--- a/testing/clapf/clapf.pre-install
+++ b/testing/clapf/clapf.pre-install
@@ -1,6 +1,6 @@
#!/bin/sh
-addgroup -S clamav 2>/dev/null
-adduser -S -D -H -s /bin/false -G clamav -g clamav clamav 2>/dev/null
+addgroup -S clapf 2>/dev/null
+adduser -S -D -H -h /var/lib/clapf -s /bin/false -G clapf -g clapf clapf 2>/dev/null
exit 0