aboutsummaryrefslogtreecommitdiffstats
path: root/testing/commons-daemon
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2020-02-22 22:50:36 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-02-22 19:26:34 -0300
commitbfe6ac7dff0dc1e773978ab6e1edd9d843dbc922 (patch)
tree6bb26240e1239f9bba253becab2d4d3ebd7ad9b2 /testing/commons-daemon
parent2ada51049a082f3782047981c45cbca97f63dd2a (diff)
downloadaports-bfe6ac7dff0dc1e773978ab6e1edd9d843dbc922.tar.bz2
aports-bfe6ac7dff0dc1e773978ab6e1edd9d843dbc922.tar.xz
testing/commons-daemon: upgrade to 1.2.2
Diffstat (limited to 'testing/commons-daemon')
-rw-r--r--testing/commons-daemon/APKBUILD24
-rw-r--r--testing/commons-daemon/rat_workaround.patch14
2 files changed, 27 insertions, 11 deletions
diff --git a/testing/commons-daemon/APKBUILD b/testing/commons-daemon/APKBUILD
index 069d6cc612..2b0bb223e7 100644
--- a/testing/commons-daemon/APKBUILD
+++ b/testing/commons-daemon/APKBUILD
@@ -1,23 +1,25 @@
# Contributor: TBK <alpine@jjtc.eu>
# Maintainer: TBK <alpine@jjtc.eu>
pkgname=commons-daemon
-pkgver=1.1.0
+pkgver=1.2.2
pkgrel=0
pkgdesc="Tools to allow Java programs to run as UNIX daemons."
url="https://commons.apache.org/daemon/"
arch="all"
license="Apache-2.0"
-options="!check" # can't get "ant test" to work correctly
+options="!check" # No test suite
depends="openjdk8-jre-base"
-makedepends="apache-ant docbook2x linux-headers openjdk8" # update --with-java when bumping openjdk
+makedepends="docbook2x libcap-dev linux-headers maven openjdk8" # update --with-java when bumping openjdk
subpackages="$pkgname-doc jsvc:_jsvc jsvc-doc:_jsvc_doc"
-source="http://mirrors.dotsrc.org/apache/commons/daemon/source/commons-daemon-$pkgver-src.tar.gz"
+source="https://mirrors.dotsrc.org/apache/commons/daemon/source/commons-daemon-$pkgver-src.tar.gz
+ rat_workaround.patch
+ "
builddir="$srcdir/$pkgname-$pkgver-src"
build() {
- # commons-daemon.jar + docs
- ant -Dcompile.source=1.6 -Dcompile.target=1.6 jar javadoc
-
+ # commons-daemon.jar
+ mvn install -DskipTests=true -Dmaven.javadoc.skip=false -B
+
# jsvc
cd "$builddir/src/native/unix"
./configure \
@@ -34,7 +36,7 @@ build() {
}
package() {
- install -Dm644 dist/$pkgname-$pkgver.jar \
+ install -Dm644 target/$pkgname-$pkgver.jar \
"$pkgdir"/usr/share/java/$pkgname-$pkgver.jar
ln -s $pkgname-$pkgver.jar "$pkgdir"/usr/share/java/$pkgname.jar
}
@@ -43,7 +45,6 @@ doc() {
default_doc
mkdir -p "$subpkgdir"/usr/share/doc/$pkgname
- cp -a "$builddir"/dist/docs/* "$subpkgdir"/usr/share/doc/$pkgname/
cp -a "$builddir"/src/docs/* "$subpkgdir"/usr/share/doc/$pkgname/
cp -a "$builddir"/src/samples "$subpkgdir"/usr/share/doc/$pkgname/
}
@@ -52,7 +53,7 @@ _jsvc() {
pkgdesc="Executes classfile that implements a Daemon interface."
url="https://commons.apache.org/proper/commons-daemon/jsvc.html"
depends="$pkgname libcap"
-
+
cd "$builddir/src/native/unix"
install -Dm755 jsvc "$subpkgdir"/usr/bin/jsvc
}
@@ -62,4 +63,5 @@ _jsvc_doc() {
install -Dm644 jsvc.1.gz "$subpkgdir"/usr/share/man/man1/jsvc.1.gz
}
-sha512sums="a370085a991cd6b121fcfb49822660dfc0aac19f164677dd2e6373750c1a526ef5a10334a8e075fd965c038198f6638b9e9130b5b13256f4a23a6c5a29959701 commons-daemon-1.1.0-src.tar.gz"
+sha512sums="aea5e25f1152be2f8855e98191d243daff97e02eb0dcb72a0ca681c2ec42f42dda038af3496e2fc9623d6d9982d63e4403149ee231745f42605a7a575ebc8cc3 commons-daemon-1.2.2-src.tar.gz
+1ede66e199e82bb788280159be238fba5d1e405c6f01b8123486397f5cc010b48df023c6a799a53de3e09c128a69842c4c2ff5adf735f0ae253ccec4eac28a5d rat_workaround.patch"
diff --git a/testing/commons-daemon/rat_workaround.patch b/testing/commons-daemon/rat_workaround.patch
new file mode 100644
index 0000000000..512a91085f
--- /dev/null
+++ b/testing/commons-daemon/rat_workaround.patch
@@ -0,0 +1,14 @@
+Apache RAT (license audit...) complains for some reason about location.o,
+ causing maven to fail. This patch is a "dirty" workaround.
+
+--- a/pom.xml
++++ b/pom.xml
+@@ -136,6 +136,8 @@
+ <exclude>src/native/unix/config.nice</exclude>
+ <exclude>src/native/unix/config.status</exclude>
+ <exclude>src/native/unix/config.log</exclude>
++ <!-- Workaround for location.o -->
++ <exclude>src/native/unix/native/location.o</exclude>
+ </excludes>
+ </configuration>
+ </plugin>