aboutsummaryrefslogtreecommitdiffstats
path: root/testing/confd
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2019-08-18 16:52:54 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2019-08-18 16:54:44 +0200
commit4cf7aa27fce588eddec1762294c199c14b510c67 (patch)
treed81d63bf4c4cf4dedc7d3aca8e633a13cd41a5f9 /testing/confd
parent58f4a684bfd113e4396bc471c192820eaaec9d19 (diff)
downloadaports-4cf7aa27fce588eddec1762294c199c14b510c67.tar.bz2
aports-4cf7aa27fce588eddec1762294c199c14b510c67.tar.xz
testing/confd: fix build with latest go
No pkgrel bump, resulting binary should be identical.
Diffstat (limited to 'testing/confd')
-rw-r--r--testing/confd/0001-add-file-backend-to-quick-start-guide-727.patch27
-rw-r--r--testing/confd/APKBUILD6
2 files changed, 31 insertions, 2 deletions
diff --git a/testing/confd/0001-add-file-backend-to-quick-start-guide-727.patch b/testing/confd/0001-add-file-backend-to-quick-start-guide-727.patch
new file mode 100644
index 0000000000..e1b16f904a
--- /dev/null
+++ b/testing/confd/0001-add-file-backend-to-quick-start-guide-727.patch
@@ -0,0 +1,27 @@
+From cccd334562329858feac719ad94b75aa87968a99 Mon Sep 17 00:00:00 2001
+From: Britt Treece <britt.treece@gmail.com>
+Date: Mon, 16 Jul 2018 04:59:03 -0500
+Subject: [PATCH] add file backend to quick start guide (#727)
+
+* add file backend to quick start guide
+
+* add formatting to file backend debug call
+
+* fix my poorly exec'ed fork update
+---
+ backends/file/client.go | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/backends/file/client.go b/backends/file/client.go
+index f7c4460..c37684a 100644
+--- a/backends/file/client.go
++++ b/backends/file/client.go
+@@ -112,7 +112,7 @@ func (c *Client) watchChanges(watcher *f
+ for {
+ select {
+ case event := <-watcher.Events:
+- log.Debug("event:", event)
++ log.Debug("event: %v", event)
+ if event.Op&fsnotify.Write == fsnotify.Write ||
+ event.Op&fsnotify.Remove == fsnotify.Remove ||
+ event.Op&fsnotify.Create == fsnotify.Create {
diff --git a/testing/confd/APKBUILD b/testing/confd/APKBUILD
index 47c12a008a..790655bdaa 100644
--- a/testing/confd/APKBUILD
+++ b/testing/confd/APKBUILD
@@ -12,7 +12,8 @@ depends=""
makedepends="go"
install=""
subpackages=""
-source="$pkgname-$pkgver.tar.gz::https://github.com/kelseyhightower/$pkgname/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/kelseyhightower/$pkgname/archive/v$pkgver.tar.gz
+ 0001-add-file-backend-to-quick-start-guide-727.patch"
build() {
export GOPATH="$srcdir"
@@ -35,4 +36,5 @@ package() {
install -Dm755 "$srcdir/src/github.com/kelseyhightower/confd/bin/confd" "$pkgdir/usr/bin/confd"
}
-sha512sums="eafabf85d1d7193847a78dcfde7b9961bdf5b634165d27acc760aff6e4ef79cac9688abdfcac049773a28f997f87ea94e6a7606ee7f7d7aaaeaa8ba67f7e48b7 confd-0.16.0.tar.gz"
+sha512sums="eafabf85d1d7193847a78dcfde7b9961bdf5b634165d27acc760aff6e4ef79cac9688abdfcac049773a28f997f87ea94e6a7606ee7f7d7aaaeaa8ba67f7e48b7 confd-0.16.0.tar.gz
+d57124541a84d2d9bc8e3de7bb463a724e39f99345da3732e9770439e6356f8e7633e8968cf8a654c43a92c5f99ede51badb8f18981214cdd827e10d702b0239 0001-add-file-backend-to-quick-start-guide-727.patch"