aboutsummaryrefslogtreecommitdiffstats
path: root/testing/connman/musl-fixes.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-04-22 07:40:51 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-04-22 07:41:19 +0000
commit71b46747aa2c97de1019cf62657967e2cfb686f7 (patch)
tree7e32e9a1a6cb379afea15dfc04ea34759c2712d0 /testing/connman/musl-fixes.patch
parent8d0f3c6c1348a40d12399dcef5df4e6f5207c310 (diff)
downloadaports-71b46747aa2c97de1019cf62657967e2cfb686f7.tar.bz2
aports-71b46747aa2c97de1019cf62657967e2cfb686f7.tar.xz
testing/connman: upgrade to 1.29
Diffstat (limited to 'testing/connman/musl-fixes.patch')
-rw-r--r--testing/connman/musl-fixes.patch45
1 files changed, 27 insertions, 18 deletions
diff --git a/testing/connman/musl-fixes.patch b/testing/connman/musl-fixes.patch
index 4fce03d02b..38cb147f7c 100644
--- a/testing/connman/musl-fixes.patch
+++ b/testing/connman/musl-fixes.patch
@@ -1,11 +1,10 @@
-diff --git a/configure.ac b/configure.ac
-index 805f02b..df211d0 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -165,6 +165,7 @@ fi
+--- ./configure.ac.orig
++++ ./configure.ac
+@@ -171,6 +171,8 @@
AM_CONDITIONAL(PPTP, test "${enable_pptp}" != "no")
AM_CONDITIONAL(PPTP_BUILTIN, test "${enable_pptp}" = "builtin")
++AC_CHECK_MEMBERS([struct in6_pktinfo.ipi6_addr], [], [], [[#include <netinet/in.h>]])
+AC_CHECK_HEADERS(execinfo.h)
AC_CHECK_HEADERS(resolv.h, dummy=yes,
AC_MSG_ERROR(resolver header files are required))
@@ -39,19 +38,6 @@ index e111150..ee4dc43 100644
static const DHCPOption client_options[] = {
{ OPTION_IP, 0x01 }, /* subnet-mask */
{ OPTION_IP | OPTION_LIST, 0x03 }, /* routers */
-@@ -435,10 +437,12 @@ static const struct in6_addr in6addr_all_dhcp_relay_agents_and_servers_mc =
- IN6ADDR_ALL_DHCP_RELAY_AGENTS_AND_SERVERS_MC_INIT;
-
- /* from netinet/in.h */
-+#if 0
- struct in6_pktinfo {
- struct in6_addr ipi6_addr; /* src/dst IPv6 address */
- unsigned int ipi6_ifindex; /* send/recv interface index */
- };
-+#endif
-
- int dhcpv6_send_packet(int index, struct dhcpv6_packet *dhcp_pkt, int len)
- {
diff --git a/src/log.c b/src/log.c
index a693bd0..9054462 100644
--- a/src/log.c
@@ -205,3 +191,26 @@ diff '--exclude=*.*o' -ru connman-1.24.orig/src/iptables.c connman-1.24/src/ipta
#include <xtables.h>
+--- ./gdhcp/common.h.orig
++++ ./gdhcp/common.h
+@@ -18,6 +18,9 @@
+ * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+ *
+ */
++#ifdef HAVE_CONFIG_H
++#include <config.h>
++#endif
+
+ #include <netinet/udp.h>
+ #include <netinet/ip.h>
+@@ -170,8 +173,8 @@
+ [OPTION_U32] = 4,
+ };
+
+-/* already defined within netinet/in.h if using GNU compiler */
+-#ifndef __USE_GNU
++/* already defined within netinet/in.h if using GNU or musl libc */
++#ifndef HAVE_STRUCT_IN6_PKTINFO_IPI6_ADDR
+ struct in6_pktinfo {
+ struct in6_addr ipi6_addr; /* src/dst IPv6 address */
+ unsigned int ipi6_ifindex; /* send/recv interface index */