aboutsummaryrefslogtreecommitdiffstats
path: root/testing/console_bridge
diff options
context:
space:
mode:
authorRuss Webber <russ@rw.id.au>2019-05-07 12:09:11 +1000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-05-28 08:56:17 +0000
commit16974b899565db5d759629428a747e85b1ed2d86 (patch)
treea07c187cf51adb1d7d27f3ecfbd26903bb907ac3 /testing/console_bridge
parentf1acd9476c060b33c8f08a571a5ee38bcf983bbc (diff)
downloadaports-16974b899565db5d759629428a747e85b1ed2d86.tar.bz2
aports-16974b899565db5d759629428a747e85b1ed2d86.tar.xz
testing/console_bridge: new aport
https://github.com/ros/console_bridge A ROS-independent package for logging that seamlessly pipes into rosconsole/rosout for ROS-dependent packages.
Diffstat (limited to 'testing/console_bridge')
-rw-r--r--testing/console_bridge/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/console_bridge/APKBUILD b/testing/console_bridge/APKBUILD
new file mode 100644
index 0000000000..f0ef0be398
--- /dev/null
+++ b/testing/console_bridge/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Russ Webber <russ@rw.id.au>
+# Maintainer: Russ Webber <russ@rw.id.au>
+pkgname=console_bridge
+pkgver=0.4.3
+pkgrel=0
+pkgdesc="Logging that seamlessly pipes into rosconsole/rosout for ROS-dependent packages."
+url="https://github.com/ros/console_bridge"
+arch="all"
+license="BSD-3-Clause"
+makedepends="cmake"
+subpackages="$pkgname-dev"
+source="console_bridge-$pkgver.tar.gz::https://github.com/ros/console_bridge/archive/$pkgver.tar.gz"
+
+build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ ${CMAKE_CROSSOPTS} .
+ make
+}
+
+check() {
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="034f69dcfe0c56b93a5bc60095afaaaa275955ff58f0ddee1a0a325eff3981c41703c8b521b43cdca5f6317d6a5775e7caf221cf2d79b5d62045b0f4315cc577 console_bridge-0.4.3.tar.gz"