aboutsummaryrefslogtreecommitdiffstats
path: root/testing/consul/APKBUILD
diff options
context:
space:
mode:
authorChristian Kampka <christian@kampka.net>2015-08-07 11:18:50 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2015-08-14 14:54:37 +0200
commitc87bc6f0874bd6b389001a8489c98da2a1e64d7d (patch)
tree0b4d18bcf203293220d637d3253d145aa2a0b27c /testing/consul/APKBUILD
parent84428018cca2cdf2faf2ae334931480afd1e433f (diff)
downloadaports-c87bc6f0874bd6b389001a8489c98da2a1e64d7d.tar.bz2
aports-c87bc6f0874bd6b389001a8489c98da2a1e64d7d.tar.xz
testing/consul: upgrade to version 0.5.2
Diffstat (limited to 'testing/consul/APKBUILD')
-rw-r--r--testing/consul/APKBUILD62
1 files changed, 18 insertions, 44 deletions
diff --git a/testing/consul/APKBUILD b/testing/consul/APKBUILD
index 3b9ec885d5..4de97d48e5 100644
--- a/testing/consul/APKBUILD
+++ b/testing/consul/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Olivier Mauras <olivier@mauras.ch>
# Maintainer:
pkgname=consul
-pkgver=0.5.0
-pkgrel=1
+pkgver=0.5.2
+pkgrel=0
pkgdesc="A tool for service discovery, monitoring and configuration"
url="https://www.consul.io/"
arch="all"
@@ -16,7 +16,6 @@ pkggroups="consul"
subpackages=""
options="!strip"
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz
- v${pkgver//./-}.json
consul.initd
consul.confd
acl.json.sample
@@ -29,24 +28,24 @@ _gourl="github.com/hashicorp/consul"
_builddir="$srcdir"/src/github.com/hashicorp
snapshot() {
- abuild clean
+ abuild clean
abuild deps
abuild fetch
- export GOPATH="$srcdir"
- mkdir -p $_builddir
- cd $_builddir
- msg "Checking out v${pkgver} tag"
- git clone -q --branch v${pkgver} https://$_gourl || return 1
- cd $pkgname
+ export GOPATH="$srcdir"
+ mkdir -p $_builddir
+ cd $_builddir
+ msg "Checking out v${pkgver} tag"
+ git clone -q --branch v${pkgver} https://$_gourl || return 1
+ cd $pkgname
# use custom godeps file
- install -D "$srcdir"/v${pkgver//./-}.json \
+ install -D "${_builddir}"/$pkgname/deps/v${pkgver//./-}.json \
$_builddir/$pkgname/Godeps/Godeps.json || return 1
- go get -v -d || return 1
+ go get -v -d || return 1
godep restore
- cd "$srcdir"
- tar zcf $pkgname-$pkgver.tar.gz src || return 1
- rsync --progress -La $pkgname-$pkgver.tar.gz \
- $_disturl || return 1
+ cd "$srcdir"
+ tar zcf $pkgname-$pkgver.tar.gz src || return 1
+ rsync --progress -La $pkgname-$pkgver.tar.gz \
+ $_disturl || return 1
cd $startdir && abuild undeps
}
@@ -61,9 +60,9 @@ prepare() {
}
build() {
- cd "$_builddir"/$pkgname || return 1
- export GOPATH="$srcdir"
- go build -v -o bin/consul \
+ cd "$_builddir"/$pkgname || return 1
+ export GOPATH="$srcdir"
+ go build -v -o bin/consul \
-ldflags "-X main.GitDescribe $pkgver" || return 1
}
@@ -88,28 +87,3 @@ package() {
install -m640 -o root -g consul "$srcdir"/$cf "$pkgdir"/etc/${pkgname} || return 1
done
}
-
-md5sums="14f03d1b12e0153a0df2a4becad6516f consul-0.5.0.tar.gz
-5594031fcbe1accb446ddb2a94a15e20 v0-5-0.json
-34adfd50f993e57f5941d77963a23eef consul.initd
-9873f8d9a30f788eda9298e89366a1c9 consul.confd
-3ecdfa3d217bf8517a2b025da321811d acl.json.sample
-3cfcc6f98d15ce3f3ac7021657786ab6 encrypt.json.sample
-75a654690d6096987d52796a6e01e405 server.json
-f16f70961c3297b54affc6f2c615873a tls.json.sample"
-sha256sums="fff18f7f624b393d96e9898afa5dd32501c09cf3a9e701ad9452fd6d972009e2 consul-0.5.0.tar.gz
-3e4e5ebadb7076e967f6dc68eb4b5a3c8b5fb03db2c4da5f95be4f8480b3b5c6 v0-5-0.json
-f6caf13d0797f1cdc3d861e3417baa4e4fc3e8beaf5698b278ce514b3af5edac consul.initd
-888aaaee84b3d8431526960becfdb123eaf438ae10fa58f59b5520ae0c0d0830 consul.confd
-40b230f47a5a52eac87cfea4cdda99125a2136630bdf49d22af0df814201f313 acl.json.sample
-927f9b480d4593a9d3dfe5e3e047e30fddc954a83157517135db3f60e7596a6f encrypt.json.sample
-1058636fbbe66890c8a04a264f1200572202b205976aa562b07fe86f4faab89f server.json
-b10bd00587a8ed56284e1c0bc9f1bdc6d556986320113ddf4e118042dc39cd2d tls.json.sample"
-sha512sums="1f30c93899e05086edd1f40f8d23c175f6f4340a8ac79e9451772638bb01c1e8ba918b94bca3261e5e6327c83e51e06125b7717249323a91394a42b4863969fe consul-0.5.0.tar.gz
-179eb44a60d6af9404b224ad7d21d67be57fdab4ee753d6ee62ef15e7febf5c2b4d7fa5e21fb718e500bbb63c40c31478dcbc7fb129c0312658e6b04e05106ca v0-5-0.json
-8510cdd05c8fa8e856cbc3806d8851adfebf64f34d7736503e6516050df6c98537e0fe334a28dc8ce2278be87ab7e1c0e09f77f26848bb6fff70f28ff702218a consul.initd
-f2c5af74dfcbca2fea8ebea31139d93f44455b93ef17ec611b880d7071af4125615dbbd23969d0d04ca636c26d7b4e7eb97f1266baa89252097f4cbc5173d817 consul.confd
-d4310dde63d3b8fc4791124bd255bf2a1402b86d00f6b1732e18b0caedb75eae6c77382e1a48f12469828ef4bb363db4580fb1aafa63fcdc97b1431f6ea96d58 acl.json.sample
-ec30ad73c13f9dd5ba15389567436dbf74c24e822cb959c6ccc40a35e36e212313c70f3cf1ccee3f63a7bb98760173d6c2478161a25b85e14dd889a47572aff1 encrypt.json.sample
-a8b984db03f0bfb652d541dbdd3f1bc9be22f16cce78f73e495cc54adea1e09e9ac0e2f306ca8436590433c80a2ef824641f790b30aea9acb806b01fcabc918e server.json
-7582f1845a742cf570db5aa52077eb4c4cbfe68ee2ae9569cc2806444217eba0ee960a3a52f3edd1a7c36ca8b7811df5cab6dd062b060ab43ed57b8c811c85de tls.json.sample"