aboutsummaryrefslogtreecommitdiffstats
path: root/testing/corestats
diff options
context:
space:
mode:
authorrahmanshaber <rahmanshaber@yahoo.com>2019-07-29 12:08:11 +0800
committerLeo <thinkabit.ukim@gmail.com>2019-07-29 03:58:52 -0300
commite7752624e4730a91bc5b180dcfa120aafe402b95 (patch)
tree48b5a3774ad4e318456011e8ba7bfb5225387bd0 /testing/corestats
parent06cc1dac8c0f9330fd46b493f13fdfb3481a8cf7 (diff)
downloadaports-e7752624e4730a91bc5b180dcfa120aafe402b95.tar.bz2
aports-e7752624e4730a91bc5b180dcfa120aafe402b95.tar.xz
testing/corestats: new aport
Diffstat (limited to 'testing/corestats')
-rw-r--r--testing/corestats/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/corestats/APKBUILD b/testing/corestats/APKBUILD
new file mode 100644
index 0000000000..56cb0c1dd1
--- /dev/null
+++ b/testing/corestats/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: rahmanshaber <rahmanshaber@yahoo.com>
+# Maintainer: rahmanshaber <rahmanshaber@yahoo.com>
+pkgname=corestats
+pkgver=2.6.0
+pkgrel=0
+pkgdesc="A system resource viewer from the CoreApps family."
+arch="all"
+url="https://gitlab.com/cubocore"
+license="GPL-2.0-only"
+depends="qt5-qtsvg"
+makedepends="qt5-qtbase-dev libcprime-dev libcsys-dev"
+source="$pkgname-$pkgver.tar.gz::https://gitlab.com/cubocore/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-v$pkgver"
+options="!check"
+
+build() {
+ qmake-qt5
+ make
+}
+
+package() {
+ INSTALL_ROOT="$pkgdir" make install
+}
+sha512sums="08726c683681598046dd071b4f814512ec204dc147855e677c8c332b5a6f2bb4a1c9cd08f65a41249f36f4d70de666fdba52c08f59bc3d5f076713d7fc29ec2c corestats-2.6.0.tar.gz"