aboutsummaryrefslogtreecommitdiffstats
path: root/testing/corkscrew/APKBUILD
diff options
context:
space:
mode:
authorMatt Dainty <matt+alpine@bodgit-n-scarper.com>2016-04-15 11:57:36 +0100
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2016-04-20 09:58:46 +0200
commit71bd1e8bdf34936afb4c70cc5c3e4b13e9f4e2bd (patch)
tree048d5a157838db286d509aa18de7dd9fdfea40b7 /testing/corkscrew/APKBUILD
parent70acb23fc0024c0e54cc297ebbf5b7cabd56193a (diff)
downloadaports-71bd1e8bdf34936afb4c70cc5c3e4b13e9f4e2bd.tar.bz2
aports-71bd1e8bdf34936afb4c70cc5c3e4b13e9f4e2bd.tar.xz
testing/corkscrew: new aport
http://agroman.net/corkscrew/ Tool for tunneling SSH through HTTP proxies
Diffstat (limited to 'testing/corkscrew/APKBUILD')
-rw-r--r--testing/corkscrew/APKBUILD65
1 files changed, 65 insertions, 0 deletions
diff --git a/testing/corkscrew/APKBUILD b/testing/corkscrew/APKBUILD
new file mode 100644
index 0000000000..6029e62766
--- /dev/null
+++ b/testing/corkscrew/APKBUILD
@@ -0,0 +1,65 @@
+# Contributor: Matt Dainty <matt+alpine@bodgit-n-scarper.com>
+# Maintainer:
+pkgname=corkscrew
+pkgver=2.0
+pkgrel=0
+pkgdesc="Tool for tunneling SSH through HTTP proxies"
+url="http://agroman.net/corkscrew/"
+arch="all"
+license="GPL"
+depends=""
+makedepends="autoconf automake"
+install=""
+subpackages="$pkgname-doc"
+source="http://agroman.net/$pkgname/$pkgname-$pkgver.tar.gz
+ corkscrew-2.0-from-debian.patch
+ corkscrew-2.0-typo.patch
+ corkscrew-2.0-autoconf.patch
+ corkscrew.1
+ "
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ aclocal && autoheader && autoconf && automake --add-missing --force || return 1
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+
+ install -m644 -D "$srcdir"/corkscrew.1 \
+ "$pkgdir"/usr/share/man/man1/corkscrew.1 || return 1
+}
+
+md5sums="35df77e7f0e59c0ec4f80313be52c10a corkscrew-2.0.tar.gz
+877c4d390dde4af6669f26ead2d4f3d9 corkscrew-2.0-from-debian.patch
+2c8c799949903a166bb08a6747a3563c corkscrew-2.0-typo.patch
+bd80d0cc791e83734d7521ccc59badb6 corkscrew-2.0-autoconf.patch
+bf041e99c7395e32460c34b3a01c9db1 corkscrew.1"
+sha256sums="0d0fcbb41cba4a81c4ab494459472086f377f9edb78a2e2238ed19b58956b0be corkscrew-2.0.tar.gz
+6dd9455f3063cab53fd95c416d5706d921d19a050794cf53df7f2f51e5a97511 corkscrew-2.0-from-debian.patch
+94a2137fbfe09b2c417dab251ce98e75ca4bc219c0002eaaeb84236f26361fe5 corkscrew-2.0-typo.patch
+b4fb8a9c40e1902f718a9e2bd03bf43976fe57903f977d20d6e81812f97ac777 corkscrew-2.0-autoconf.patch
+67f442ffccda98b05a1b4b42c9e4064f538467361d36fcca1401398efd3a44b2 corkscrew.1"
+sha512sums="bfea81064601cdf67ba1730b49e3a5f7aa377423edbfb052ff0f6b2776b49e104852b7f126f4668d37541a706313ef37d9b4535126e94bb202db4ac38f693e6f corkscrew-2.0.tar.gz
+58b8360155aefc636dfed3c1be89ebbcf39b623dacea12d1fdf3c5831f3b6d06c4f8510a3ccc125f24644a0ca27606c10af99e22266fdd7eca5a3677504f88fb corkscrew-2.0-from-debian.patch
+6a685588231485b3808909d12885ed4265f9dd471bf89774ee7f4603577a866c16b296642f223c5ca91eb75c71c552d3aac249bed451dcdffbdacc19abda309d corkscrew-2.0-typo.patch
+3ad3ac14717e2f8120bd7415426232e081cdc3a1c46437a54a4e27f7cc3777ecf266cd52a9917a48317dedc5c529363a404d4ff556f20c52bf0c00ee4003e799 corkscrew-2.0-autoconf.patch
+a59c99056ef4c12dec854ab0b571b9778b78c3d429193c1365ef2c1a37edb478e8d7e7948e830b22dfe3fb724e6be0b6176ac541da1fa5a2678a608f2b025e90 corkscrew.1"