aboutsummaryrefslogtreecommitdiffstats
path: root/testing/createrepo_c/10-libdir.patch
diff options
context:
space:
mode:
authorPaul Morgan <jumanjiman@gmail.com>2017-08-22 22:07:45 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-08-24 22:39:56 +0000
commit00007ce8cecd281a981e9c6c80b64f5f3cb8a6e9 (patch)
tree3354725befd6c648341866f8145dbf586634563c /testing/createrepo_c/10-libdir.patch
parente0737a368b7243d1ef9432e0e26136951af363bd (diff)
downloadaports-00007ce8cecd281a981e9c6c80b64f5f3cb8a6e9.tar.bz2
aports-00007ce8cecd281a981e9c6c80b64f5f3cb8a6e9.tar.xz
testing/createrepo_c: new aport
This is a C implementation of createrepo and is smaller and faster than (the python-based) createrepo. The base package provides utilities to manipulate yum repositories: - createrepo_c - mergerepo_c - modifyrepo_c - sqliterepo_c Subpackages provide additional features.
Diffstat (limited to 'testing/createrepo_c/10-libdir.patch')
-rw-r--r--testing/createrepo_c/10-libdir.patch8
1 files changed, 8 insertions, 0 deletions
diff --git a/testing/createrepo_c/10-libdir.patch b/testing/createrepo_c/10-libdir.patch
new file mode 100644
index 0000000000..82848b4030
--- /dev/null
+++ b/testing/createrepo_c/10-libdir.patch
@@ -0,0 +1,8 @@
+--- ./src/CMakeLists.txt.orig
++++ ./src/CMakeLists.txt
+@@ -110,4 +110 @@
+-IF (CMAKE_SIZEOF_VOID_P MATCHES "8")
+- SET (LIB_SUFFIX "64")
+-ENDIF (CMAKE_SIZEOF_VOID_P MATCHES "8")
+-SET (LIB_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}")
++SET (LIB_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}")