aboutsummaryrefslogtreecommitdiffstats
path: root/testing/createrepo_c
diff options
context:
space:
mode:
authorPaul Morgan <jumanjiman@gmail.com>2018-11-24 13:26:47 +0000
committerAndy Postnikov <apostnikov@gmail.com>2018-11-24 18:28:57 +0200
commit49a35677347232d3dd06428c9eafb23162d1ffa4 (patch)
tree13afb9269f5586b3fcccf594dbb693903c42b193 /testing/createrepo_c
parent978cc30dcb9baa6a91c68cd1188c3772a3a33b1e (diff)
downloadaports-49a35677347232d3dd06428c9eafb23162d1ffa4.tar.bz2
aports-49a35677347232d3dd06428c9eafb23162d1ffa4.tar.xz
testing/createrepo_c: upgrade to 0.11.1
Changes in upstream since previous packaged version: - Fix "CR_DELTA_RPM_SUPPORT" redefined warnings - Set to build against Python 3 by default - Update README - Add mergerepo_c --repo-prefix-search and --repo-prefix-replace. - Fix missing packages in mergerepo_c in case multiple VR exists for single pkg in repo. - Enable support for processing legacy tags by default - Correctly identify Requires(missingok) dependencies as legacy Recommends - Change location of drpm code to new address in GitHub Note: Upstream git log says it defaults to Python3. Actually it detects the version of Python and builds accordingly. Therefore this package continues to provide Python2 bindings in the `py2-createrepo_c` subpackage to avoid churn. A future commit can convert the subpackage from Python2 to Python3.
Diffstat (limited to 'testing/createrepo_c')
-rw-r--r--testing/createrepo_c/APKBUILD22
1 files changed, 5 insertions, 17 deletions
diff --git a/testing/createrepo_c/APKBUILD b/testing/createrepo_c/APKBUILD
index 02de94d91a..57f8abc34b 100644
--- a/testing/createrepo_c/APKBUILD
+++ b/testing/createrepo_c/APKBUILD
@@ -1,20 +1,8 @@
# Contributor:
# Maintainer: Paul Morgan <jumanjiman@gmail.com>
pkgname=createrepo_c
-
-# This is awful, but it allows to create package with recent commits.
-# Upstream has not tagged a release in nearly two years, but
-# they have commits in master that we want to use.
-# Follow the lead of 'git-describe' and
-# append a number that represents the number of commits since last tag.
-# After upstream releases a new tag, go back to normal alpine versioning.
-# git_describe="0.10.0-48-g0cac54d"
-treeish="0cac54d09b5a2140b625cabad95dc48898e25cdd"
-upstream_tag=0.10.0
-commits_since=48
-
-pkgver=${upstream_tag}.${commits_since}
-pkgrel=3
+pkgver=0.11.1
+pkgrel=0
pkgdesc="C implementation of createrepo"
url="https://github.com/rpm-software-management/createrepo_c/"
arch="all"
@@ -51,10 +39,10 @@ subpackages="
py2-${pkgname}:py2
"
source="
- ${pkgname}-${treeish}.tar.gz::https://github.com/rpm-software-management/createrepo_c/archive/${treeish}.tar.gz
+ ${pkgname}-${pkgver}.tar.gz::https://github.com/rpm-software-management/createrepo_c/archive/${pkgver}.tar.gz
10-libdir.patch
"
-builddir="${srcdir}/${pkgname}-${treeish}/"
+builddir="${srcdir}/${pkgname}-${pkgver}/"
build() {
mkdir "${builddir}"/build
@@ -104,5 +92,5 @@ bashcomp() {
mv "${pkgdir}"/usr/share/bash-completion "${subpkgdir}"/usr/share/
}
-sha512sums="e1e76d4a7c27af812d2ccf48512491377baeaa2506617ef6a6070dd04327a48b7f16e07bf8e84f8793db3fb5c8d0b79cd88cee4f013f86be2244a5750ccf08c0 createrepo_c-0cac54d09b5a2140b625cabad95dc48898e25cdd.tar.gz
+sha512sums="b07b656a625c4637f521b6bcff1d4eb22df930b9033824dd7ccbd6e7eea66aa4df4c52cc84bc32391d20013bb3c06c02afcb8801c676af5ad860992197681e7a createrepo_c-0.11.1.tar.gz
df861d341d2acf5aba85d2bf0b959a7b22a29315efb0efeeada3871d7f1c4be035d27ff2408f55f3df24e6e11a8e5d7c4c88fd0ce25e4377b5452e861b40e188 10-libdir.patch"