aboutsummaryrefslogtreecommitdiffstats
path: root/testing/csync/APKBUILD
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2015-09-29 19:48:03 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2015-09-29 19:48:03 +0200
commit15db65c3b71a39289fd84d0c19582f250c89efae (patch)
tree45969d3527d606f7206186dc150e7d2ad2f0220b /testing/csync/APKBUILD
parente080f0575da64ae04531610d9ab1fefe7e132a44 (diff)
downloadaports-15db65c3b71a39289fd84d0c19582f250c89efae.tar.bz2
aports-15db65c3b71a39289fd84d0c19582f250c89efae.tar.xz
testing/csync: fix build with gcc 5 versions
See: https://www.gnu.org/software/gcc/gcc-5/porting_to.html
Diffstat (limited to 'testing/csync/APKBUILD')
-rw-r--r--testing/csync/APKBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/testing/csync/APKBUILD b/testing/csync/APKBUILD
index abae67048b..6c9e873d72 100644
--- a/testing/csync/APKBUILD
+++ b/testing/csync/APKBUILD
@@ -14,7 +14,7 @@ install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-sftp $pkgname-smb $pkgname-owncloud"
source="https://open.cryptomilk.org/attachments/download/27/csync-$pkgver.tar.xz
iconv.patch
- "
+ gcc-fixes.patch"
_builddir="$srcdir"/csync-$pkgver
prepare() {
@@ -33,8 +33,7 @@ build() {
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
- .. \
- || return 1
+ .. || return 1
make || return 1
}
@@ -59,8 +58,11 @@ sftp() { _plugin sftp; }
owncloud() { _plugin owncloud; }
md5sums="4f022aaa19ecd8008b03876dd65a9df2 csync-0.50.0.tar.xz
-166e828bf574dbfc1857b04985ec699b iconv.patch"
+166e828bf574dbfc1857b04985ec699b iconv.patch
+70a120f5f913fb44f66844734e200131 gcc-fixes.patch"
sha256sums="c07526942a93c1e213d354dc45fd61fbc0430c60e109e7a2f0fcaf6213a45c86 csync-0.50.0.tar.xz
-1a64b9ad6bc8c79b16ae8f6eb31ca2d3e124132e8130b908925d60ddc0eea98c iconv.patch"
+1a64b9ad6bc8c79b16ae8f6eb31ca2d3e124132e8130b908925d60ddc0eea98c iconv.patch
+1bb262390c687780dc65adb36f0c89c7c04d3db235d69d1cae9280c8c6029cae gcc-fixes.patch"
sha512sums="babe44af3a4f0bf58e011f1c33c7a6df9bc7751e03714dd64d8269c7c51bcc7f2ab32c4d286e5a11465c9498c988d1812c426a4f415f1138a4fb9fa341e1e29a csync-0.50.0.tar.xz
-fc124966d7b7405cc3d3bc1276180089dc44058bc89afa799c0d9378f4dc131e9382b96357fff5964c9b009cb77455f125b63557a32ca5eaa31e01cbd2f7a694 iconv.patch"
+fc124966d7b7405cc3d3bc1276180089dc44058bc89afa799c0d9378f4dc131e9382b96357fff5964c9b009cb77455f125b63557a32ca5eaa31e01cbd2f7a694 iconv.patch
+88290d1dfbfeb775d89f4fbd20b9909a3fe5896ae85496eb53a0bd78162427ba7d910852ffb1887dcf380ad89e46c909d29e0a54f020c3ea92e613ac860b1b99 gcc-fixes.patch"