aboutsummaryrefslogtreecommitdiffstats
path: root/testing/csync/iconv.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-11-23 13:16:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-11-23 14:24:06 +0000
commit396a5fc923310d8d66a101f011a79c89d62ff598 (patch)
treefaad65d56f1041471466dcb8c4591d2f4dae74b2 /testing/csync/iconv.patch
parent84c2517366c88572fcad44b782019811ae18f77b (diff)
downloadaports-396a5fc923310d8d66a101f011a79c89d62ff598.tar.bz2
aports-396a5fc923310d8d66a101f011a79c89d62ff598.tar.xz
testing/csync: new aport
a client only bidirectional file synchronizer http://www.csync.org/
Diffstat (limited to 'testing/csync/iconv.patch')
-rw-r--r--testing/csync/iconv.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/csync/iconv.patch b/testing/csync/iconv.patch
new file mode 100644
index 0000000000..fcafeb3a80
--- /dev/null
+++ b/testing/csync/iconv.patch
@@ -0,0 +1,26 @@
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 1cc90bc..f8309dd 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -28,7 +28,7 @@ set(CSYNC_LINK_LIBRARIES
+ ${SQLITE3_LIBRARIES}
+ )
+
+-if(HAVE_ICONV AND WITH_ICONV)
++if(WITH_ICONV)
+ list(APPEND CSYNC_PRIVATE_INCLUDE_DIRS ${ICONV_INCLUDE_DIR})
+ list(APPEND CSYNC_LINK_LIBRARIES ${ICONV_LIBRARIES})
+ endif()
+diff --git a/src/std/c_string.c b/src/std/c_string.c
+index f175734..ccc0644 100644
+--- a/src/std/c_string.c
++++ b/src/std/c_string.c
+@@ -39,7 +39,7 @@
+ #include <windows.h>
+ #endif
+
+-#if defined(HAVE_ICONV) && defined(WITH_ICONV)
++#if defined(WITH_ICONV)
+ # ifdef HAVE_ICONV_H
+ # include <iconv.h>
+ # endif