aboutsummaryrefslogtreecommitdiffstats
path: root/testing/csync2
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-03-18 13:21:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-03-18 13:50:24 +0000
commitf7ef0bae139f071bac6bad920b035881421b5026 (patch)
tree6a347767864737ea9abea61f89a34a2c9e655e60 /testing/csync2
parent54252930687e5adf0de0ec3d4ff63ebcc8276bad (diff)
downloadaports-f7ef0bae139f071bac6bad920b035881421b5026.tar.bz2
aports-f7ef0bae139f071bac6bad920b035881421b5026.tar.xz
testing/csync2: rebuild with librsync-1.0
Diffstat (limited to 'testing/csync2')
-rw-r--r--testing/csync2/APKBUILD17
-rw-r--r--testing/csync2/csync2-1.34-librsync-1.0.0.patch35
2 files changed, 49 insertions, 3 deletions
diff --git a/testing/csync2/APKBUILD b/testing/csync2/APKBUILD
index 8ee0c9ea76..f26da55cbc 100644
--- a/testing/csync2/APKBUILD
+++ b/testing/csync2/APKBUILD
@@ -2,7 +2,7 @@
pkgname=csync2
pkgver=1.34_git20111201
_ver=${pkgver%_git*}
-pkgrel=0
+pkgrel=2
pkgdesc="Cluster synchronization tool"
url="http://oss.linbit.com/csync2/"
arch="all"
@@ -13,7 +13,9 @@ install=
subpackages="$pkgname-doc"
source="http://oss.linbit.com/csync2/csync2-${_ver}.tar.gz
git.patch
- 03-strlcpy_disable.patch"
+ 03-strlcpy_disable.patch
+ csync2-1.34-librsync-1.0.0.patch
+ "
# 01-csync2-sqlite3.patch
# 02-csync2-1.34-gnutls_pkgconfig.patch
@@ -69,4 +71,13 @@ package() {
md5sums="efc8a3548996b79cef2ad76af5e93cd8 csync2-1.34.tar.gz
bd4957d25e984518d929ae4036bf0ae9 git.patch
-e6d8aaff70cf847b11873cd1cfaaa8f6 03-strlcpy_disable.patch"
+e6d8aaff70cf847b11873cd1cfaaa8f6 03-strlcpy_disable.patch
+943227a4ca4bdd5ec37a315dba1844d3 csync2-1.34-librsync-1.0.0.patch"
+sha256sums="32b250dd4a0353f71015c5c3961174b975dd5e799e4a084e8f6d00792bd8c833 csync2-1.34.tar.gz
+7174ff0cb464b8f74c3816bfe3c5a89e9b876b50dcd6a7440b7488e3561668d7 git.patch
+f4a44ca3f3a33a413a96ce837d5569c3d802bce4a6a960593b014d8dcbfbc136 03-strlcpy_disable.patch
+320ac974d6bbebddea5bc08b92c944189733742e2db8c3580e193ca9a2b934ee csync2-1.34-librsync-1.0.0.patch"
+sha512sums="a24154446740f3362c10a23d526c29e96292f2ad56a9ed2f11ca0a6d7afed3730d0e96f8ebc2c6cdcc17031aa0e368f6ba93084ad3cf5f4828fbc279e6f004d8 csync2-1.34.tar.gz
+ff47b30e86f6266b4be85a47db52409169597d97e4ec086653af3341978cce5e477054e5746f3824aed1d8c7949e5f8451b2bd675442a9a2c9c5c519918438a9 git.patch
+1b82b25acfb988cd8f92117f6ea4bc22247648448751adc0958dae0ade3c1eb065ad15f7104e4860ea2f08a91a368d68e3959ef5dfa278c254857382ebb64625 03-strlcpy_disable.patch
+f44e1df35aefff2900a5983fd1e368864396757e1fcfd6e3f5d39a55c1bad6e42e8bca5f0e16aa641dff3b62a27d7d5413dc907bcd19b9d4de068fd7be7214b0 csync2-1.34-librsync-1.0.0.patch"
diff --git a/testing/csync2/csync2-1.34-librsync-1.0.0.patch b/testing/csync2/csync2-1.34-librsync-1.0.0.patch
new file mode 100644
index 0000000000..d46653d455
--- /dev/null
+++ b/testing/csync2/csync2-1.34-librsync-1.0.0.patch
@@ -0,0 +1,35 @@
+Patch by Robert Scheck <robert@fedoraproject.org> for csync2 <= 1.34 based on the
+patch by Roman Tereshonkov and Kari Hautio to avoid a build failure with librsync
+>= 1.0.0 (which is a security bugfix release). The discussion and solution finding
+can be found at https://bugs.launchpad.net/duplicity/+bug/1416344 (for duplicity).
+
+--- csync2-1.34/rsync.c 2007-07-24 23:04:18.000000000 +0200
++++ csync2-1.34/rsync.c.librsync-1.0.0 2015-03-02 00:18:43.000000000 +0100
+@@ -134,8 +134,13 @@
+
+ if ( isreg ) {
+ csync_debug(3, "Running rs_sig_file() from librsync....\n");
++#ifdef RS_DEFAULT_STRONG_LEN
+ result = rs_sig_file(basis_file, sig_file,
+ RS_DEFAULT_BLOCK_LEN, RS_DEFAULT_STRONG_LEN, &stats);
++#else /* librsync >= 1.0.0 */
++ result = rs_sig_file(basis_file, sig_file,
++ RS_DEFAULT_BLOCK_LEN, 8, RS_MD4_SIG_MAGIC, &stats);
++#endif
+ if (result != RS_DONE) {
+ csync_debug(0, "Internal error from rsync library!\n");
+ goto error;
+@@ -216,8 +221,13 @@
+ if ( !basis_file ) basis_file = fopen("/dev/null", "rb");
+
+ csync_debug(3, "Running rs_sig_file() from librsync..\n");
++#ifdef RS_DEFAULT_STRONG_LEN
+ result = rs_sig_file(basis_file, sig_file,
+ RS_DEFAULT_BLOCK_LEN, RS_DEFAULT_STRONG_LEN, &stats);
++#else /* librsync >= 1.0.0 */
++ result = rs_sig_file(basis_file, sig_file,
++ RS_DEFAULT_BLOCK_LEN, 8, RS_MD4_SIG_MAGIC, &stats);
++#endif
+ if (result != RS_DONE)
+ csync_fatal("Got an error from librsync, too bad!\n");
+