aboutsummaryrefslogtreecommitdiffstats
path: root/testing/csync
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2015-09-29 20:03:13 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2015-09-29 20:03:13 +0200
commitdbe6d42e672ef282c6afcb5a15fac55f1e55d284 (patch)
treed815b5231a87461fe032a20f5d2c8f70e7fea7b2 /testing/csync
parent15db65c3b71a39289fd84d0c19582f250c89efae (diff)
downloadaports-dbe6d42e672ef282c6afcb5a15fac55f1e55d284.tar.bz2
aports-dbe6d42e672ef282c6afcb5a15fac55f1e55d284.tar.xz
testing/csync: call _plugin helper function directly
Diffstat (limited to 'testing/csync')
-rw-r--r--testing/csync/APKBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/testing/csync/APKBUILD b/testing/csync/APKBUILD
index 6c9e873d72..7df5f5d65f 100644
--- a/testing/csync/APKBUILD
+++ b/testing/csync/APKBUILD
@@ -11,7 +11,12 @@ depends_dev=""
makedepends="$depends_dev check-dev samba-dev libssh-dev cmake sqlite-dev
iniparser-dev neon-dev"
install=""
-subpackages="$pkgname-dev $pkgname-doc $pkgname-sftp $pkgname-smb $pkgname-owncloud"
+subpackages="
+ $pkgname-dev
+ $pkgname-doc
+ $pkgname-sftp:_plugin
+ $pkgname-smb:_plugin
+ $pkgname-owncloud:_plugin"
source="https://open.cryptomilk.org/attachments/download/27/csync-$pkgver.tar.xz
iconv.patch
gcc-fixes.patch"
@@ -44,19 +49,17 @@ package() {
}
_plugin() {
+ local _name="${subpkgname##*-}"
pkgdesc="csync $1 plugin"
- cd "$pkgdir"
+
local i
- for i in usr/lib/csync*/csync_$1.so; do
+ cd "$pkgdir"
+ for i in usr/lib/csync*/csync_${_name}.so; do
mkdir -p "$subpkgdir"/${i%/*}
mv $i "$subpkgdir"/${i%/*}
done
}
-smb() { _plugin smb; }
-sftp() { _plugin sftp; }
-owncloud() { _plugin owncloud; }
-
md5sums="4f022aaa19ecd8008b03876dd65a9df2 csync-0.50.0.tar.xz
166e828bf574dbfc1857b04985ec699b iconv.patch
70a120f5f913fb44f66844734e200131 gcc-fixes.patch"