aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cwm
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-01-06 05:41:07 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-06 06:07:38 +0100
commitd5d2c4d65d6224a8eb12075c6195b86391a16dd1 (patch)
treedd166e060a1e48aedd3fe25832f2e0bdd6877f50 /testing/cwm
parent82dbb5c6aa11bab97b4c8d1cecc1a31016810a21 (diff)
downloadaports-d5d2c4d65d6224a8eb12075c6195b86391a16dd1.tar.bz2
aports-d5d2c4d65d6224a8eb12075c6195b86391a16dd1.tar.xz
testing/cwm: upgrade to 6.6
Diffstat (limited to 'testing/cwm')
-rw-r--r--testing/cwm/APKBUILD13
-rw-r--r--testing/cwm/menu-border.patch13
2 files changed, 3 insertions, 23 deletions
diff --git a/testing/cwm/APKBUILD b/testing/cwm/APKBUILD
index 235761826e..d6d8925814 100644
--- a/testing/cwm/APKBUILD
+++ b/testing/cwm/APKBUILD
@@ -1,29 +1,22 @@
# Contributor: Cág <ca6c@bitmessage.ch>
# Maintainer
pkgname=cwm
-pkgver=6.3
+pkgver=6.6
pkgrel=0
pkgdesc="A lightweight and efficient window manager for X11"
url="https://github.com/chneukirchen/cwm"
arch="all"
license="ISC"
-depends=""
makedepends="libx11-dev libxft-dev libxrandr-dev byacc bsd-compat-headers"
-install=""
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/chneukirchen/$pkgname/archive/v$pkgver.tar.gz
- menu-border.patch"
-builddir="$srcdir/$pkgname-$pkgver"
+source="cwm-$pkgver.tar.gz::https://github.com/chneukirchen/cwm/archive/v$pkgver.tar.gz"
build() {
- cd "$builddir"
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir/" PREFIX=/usr install
}
-sha512sums="12f5c28ce2fa8e5310c49dd6d4fb58140a514943a93b8cab1c0c604bb50535a5e6b00b10f21c8d4500440f7ae7b14d2cb23c65eb201578fc01ab09f2bbc1e91f cwm-6.3.tar.gz
-d83c250af671de4d3ba9fcec6b1f72dfa9c36962e392521315987088f04c76830aef49a91f8e63f7be3e3895e3bf8ef0cc874c8ebb9e6e541accd2fae70fe2b8 menu-border.patch"
+sha512sums="ff94fd1b7d263f9de538e5b338db58a08e1bec3e4233b84ab0a3ac94c47a45e10b2c772f93b897e70baf9a3c04e1a6fa04604ac71655acb7ebd1d10edb381042 cwm-6.6.tar.gz"
diff --git a/testing/cwm/menu-border.patch b/testing/cwm/menu-border.patch
deleted file mode 100644
index 290b60576a..0000000000
--- a/testing/cwm/menu-border.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/conf.c b/conf.c
-index d750c42..20a2da5 100644
---- a/conf.c
-+++ b/conf.c
-@@ -478,7 +478,7 @@ conf_screen(struct screen_ctx *sc)
-
- sc->menu.win = XCreateSimpleWindow(X_Dpy, sc->rootwin, 0, 0, 1, 1,
- Conf.bwidth,
-- sc->xftcolor[CWM_COLOR_MENU_FG].pixel,
-+ sc->xftcolor[CWM_COLOR_BORDER_ACTIVE].pixel,
- sc->xftcolor[CWM_COLOR_MENU_BG].pixel);
-
- sc->menu.xftdraw = XftDrawCreate(X_Dpy, sc->menu.win, visual, colormap);