aboutsummaryrefslogtreecommitdiffstats
path: root/testing/daemontools/0.76-warnings.patch
diff options
context:
space:
mode:
authorJohannes Findeisen <you@hanez.org>2016-11-18 20:25:16 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2016-12-05 16:12:21 +0000
commit8e66643b26e958ab57aa9507d5ebd0ad9fa719a2 (patch)
treefe82af300ba8e655425521f78d7d5d48ca93cdde /testing/daemontools/0.76-warnings.patch
parent1b30f2804b6f5c59ab10eec4d850332a762a15e3 (diff)
downloadaports-8e66643b26e958ab57aa9507d5ebd0ad9fa719a2.tar.bz2
aports-8e66643b26e958ab57aa9507d5ebd0ad9fa719a2.tar.xz
testing/daemontools: made APKBUILD more consistent
* fixed small errors in APKBUILD * switched to openrc-run in init script
Diffstat (limited to 'testing/daemontools/0.76-warnings.patch')
-rw-r--r--testing/daemontools/0.76-warnings.patch74
1 files changed, 74 insertions, 0 deletions
diff --git a/testing/daemontools/0.76-warnings.patch b/testing/daemontools/0.76-warnings.patch
new file mode 100644
index 0000000000..f558bb18b1
--- /dev/null
+++ b/testing/daemontools/0.76-warnings.patch
@@ -0,0 +1,74 @@
+Fixup misc warnings
+
+Patch by RiverRat
+
+http://bugs.gentoo.org/124487
+
+--- src/chkshsgr.c
++++ src/chkshsgr.c
+@@ -1,10 +1,13 @@
+ /* Public domain. */
+
++#include <sys/types.h>
++#include <stdlib.h>
++#include <grp.h>
+ #include <unistd.h>
+
+ int main()
+ {
+- short x[4];
++ gid_t x[4];
+
+ x[0] = x[1] = 0;
+ if (getgroups(1,x) == 0) if (setgroups(1,x) == -1) _exit(1);
+--- src/matchtest.c
++++ src/matchtest.c
+@@ -1,3 +1,4 @@
++#include <unistd.h>
+ #include "match.h"
+ #include "buffer.h"
+ #include "str.h"
+--- src/multilog.c
++++ src/multilog.c
+@@ -1,3 +1,4 @@
++#include <stdio.h>
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+--- src/prot.c
++++ src/prot.c
+@@ -1,5 +1,8 @@
+ /* Public domain. */
+
++#include <sys/types.h>
++#include <unistd.h>
++#include <grp.h>
+ #include "hasshsgr.h"
+ #include "prot.h"
+
+--- src/seek_set.c
++++ src/seek_set.c
+@@ -1,6 +1,7 @@
+ /* Public domain. */
+
+ #include <sys/types.h>
++#include <unistd.h>
+ #include "seek.h"
+
+ #define SET 0 /* sigh */
+--- src/supervise.c
++++ src/supervise.c
+@@ -1,3 +1,4 @@
++#include <stdio.h>
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+--- src/pathexec_run.c
++++ src/pathexec_run.c
+@@ -1,5 +1,6 @@
+ /* Public domain. */
+
++#include <unistd.h>
+ #include "error.h"
+ #include "stralloc.h"
+ #include "str.h"