aboutsummaryrefslogtreecommitdiffstats
path: root/testing/daemontools/svscan.initd
diff options
context:
space:
mode:
authorJohannes Findeisen <you@hanez.org>2016-11-18 20:25:16 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2016-12-05 16:12:21 +0000
commit8e66643b26e958ab57aa9507d5ebd0ad9fa719a2 (patch)
treefe82af300ba8e655425521f78d7d5d48ca93cdde /testing/daemontools/svscan.initd
parent1b30f2804b6f5c59ab10eec4d850332a762a15e3 (diff)
downloadaports-8e66643b26e958ab57aa9507d5ebd0ad9fa719a2.tar.bz2
aports-8e66643b26e958ab57aa9507d5ebd0ad9fa719a2.tar.xz
testing/daemontools: made APKBUILD more consistent
* fixed small errors in APKBUILD * switched to openrc-run in init script
Diffstat (limited to 'testing/daemontools/svscan.initd')
-rw-r--r--testing/daemontools/svscan.initd33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/daemontools/svscan.initd b/testing/daemontools/svscan.initd
new file mode 100644
index 0000000000..0b855ee730
--- /dev/null
+++ b/testing/daemontools/svscan.initd
@@ -0,0 +1,33 @@
+#!/sbin/openrc-run
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/daemontools/files/svscan.init-0.76-r7,v 1.1 2008/12/07 06:59:37 robbat2 Exp $
+
+depend() {
+ use net
+ before ntpd ntp-client spamd apache apache2
+ after firewall
+}
+
+start() {
+ ebegin "Starting service scan"
+ setsid start-stop-daemon --start --exec /usr/bin/svscan \
+ --background --make-pidfile \
+ --pidfile /var/run/svscan.pid -- /service
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping service scan"
+ start-stop-daemon --stop --exec /usr/bin/svscan \
+ --pidfile /var/run/svscan.pid
+ eend $?
+
+ ebegin "Stopping service scan services"
+ svc -dx /service/* 2>/dev/null
+ eend $?
+
+ ebegin "Stopping service scan logging"
+ svc -dx /service/*/log 2>/dev/null
+ eend $?
+}