aboutsummaryrefslogtreecommitdiffstats
path: root/testing/dahdi-linux-grsec/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-12-19 15:32:54 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-12-19 15:40:27 +0000
commitd9c69e5cb03366a6a7e1c311d0b5556fbbc268b2 (patch)
treed4cc3e0ab93fde4ee8756cff71160edafe7e7c82 /testing/dahdi-linux-grsec/APKBUILD
parent77da2c25ea050d11f82e909476fb53aff21ba611 (diff)
downloadaports-d9c69e5cb03366a6a7e1c311d0b5556fbbc268b2.tar.bz2
aports-d9c69e5cb03366a6a7e1c311d0b5556fbbc268b2.tar.xz
testing/dahdi-linux-grsec: rebuild against 3.4.24 kernel
Diffstat (limited to 'testing/dahdi-linux-grsec/APKBUILD')
-rw-r--r--testing/dahdi-linux-grsec/APKBUILD93
1 files changed, 93 insertions, 0 deletions
diff --git a/testing/dahdi-linux-grsec/APKBUILD b/testing/dahdi-linux-grsec/APKBUILD
new file mode 100644
index 0000000000..87d63d4c90
--- /dev/null
+++ b/testing/dahdi-linux-grsec/APKBUILD
@@ -0,0 +1,93 @@
+# Contributor: Timo Teras <timo.teras@iki.fi>
+# Maintainer: Timo Teras <timo.teras@iki.fi>
+
+_flavor=grsec
+_kver=3.4.24
+_kpkgrel=0
+_mypkgrel=0
+
+# verify the kernel version before entering chroot
+if [ -f ../linux-${_flavor}/APKBUILD ]; then
+ . ../linux-${_flavor}/APKBUILD
+ [ "$_kver" != "$pkgver" ] && die "dahdi-linux-grsec: please update _kver to $pkgver"
+ [ "$_kpkgrel" != "$pkgrel" ] && die "dahdi-linuc-grsec: please update _kpkgrel to $pkgrel"
+fi
+
+_kpkgver="$_kver-r$_kpkgrel"
+_abi_release=${_kver}-${_flavor}
+_realname=dahdi-linux
+
+pkgname=${_realname}-${_flavor}
+pkgver=$_kver
+# when chaning _dahdiver we *must* bump _mypkgrel
+_dahdiver=2.6.1
+pkgrel=$(( $_kpkgrel + $_mypkgrel ))
+pkgdesc="Digium Asterisk Hardware Device Interface drivers $_dahdiver"
+url="http://www.asterisk.org"
+arch="all"
+license="GPL"
+depends="dahdi-linux linux-${_flavor}=${_kpkgver}"
+# we need wget and tar because make install downloads firmware and uses fancy
+# options for tar and wget.
+makedepends="linux-${_flavor}-dev=${_kpkgver} wget tar perl"
+install=
+subpackages="$pkgname-dev"
+source="http://downloads.digium.com/pub/telephony/dahdi-linux/releases/${_realname}-$_dahdiver.tar.gz
+ dahdi-depmod.patch
+ dahdi-bri_dchan.patch
+ dahdi-zaphfc.patch
+ zaphfc-dahdi-flortz.diff
+ zaphfc-dahdi-2.4.0.patch
+ zaphfc-dahdi-2.5.0.patch
+ zaphfc-dahdi-2.6.0.patch
+ constify.patch
+ "
+# dahdi-2.5.0-bri-fixes.patch
+
+prepare() {
+ cd "$srcdir/$_realname-$_dahdiver"
+ for i in $source; do
+ case $i in
+ *.patch|*.diff)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+}
+
+build() {
+ cd "$srcdir/$_realname-$_dahdiver"
+ export GCC_SPECS=/usr/share/gcc/hardenednopie.specs
+ make KVERS="${_abi_release}" DYNFS="yes" MODULES_EXTRA="zaphfc" \
+ || return 1
+}
+
+package() {
+ cd "$srcdir/$_realname-$_dahdiver"
+ make KVERS="${_abi_release}" DYNFS="yes" MODULES_EXTRA="zaphfc" \
+ DESTDIR="$pkgdir" install-modules || return 1
+ rm -rf "$pkgdir"/lib/firmware "$pkgdir"/usr/lib/hotplug/firmware \
+ "$pkgdir"/usr/include
+}
+
+# since we sourced the APKBUILD above we got the dev() function there to
+# so we override it again.
+depends_dev="dahdi-linux-dev"
+dev() {
+ default_dev
+ local dir="$subpkgdir"/usr/src/dahdi-headers-${_abi_release}
+ install -D "$srcdir"/$_realname-$_dahdiver/drivers/dahdi/Module.symvers \
+ "$dir"/drivers/dahdi/Module.symvers
+ ln -s /usr/include "$dir"/include
+}
+
+md5sums="75932fe3d4a6e656165aaaa7a1377305 dahdi-linux-2.6.1.tar.gz
+c78fb8d80f9efdffd950297c88ff9273 dahdi-depmod.patch
+3bb419ac598534cd4ad5248f23656001 dahdi-bri_dchan.patch
+c6308ea8aaafba0a9d7f9825d7c9dcf8 dahdi-zaphfc.patch
+035a6d91b2fb56a9b76a60a2e494fe9e zaphfc-dahdi-flortz.diff
+0fdcd8c8c93bc1fe33c0af12b6cc6b05 zaphfc-dahdi-2.4.0.patch
+9ed23321512274c6c5c5b76af0411e38 zaphfc-dahdi-2.5.0.patch
+6273db53267e1f322d91bf1c8b97ba19 zaphfc-dahdi-2.6.0.patch
+15fd0337d9e592f2f1829770c2e69c86 constify.patch"