aboutsummaryrefslogtreecommitdiffstats
path: root/testing/darktable
diff options
context:
space:
mode:
authorKevin Daudt <me@ikke.info>2016-10-17 18:56:11 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-11-17 14:43:05 +0100
commit838767d46799cd06e0562c1e9bc440ad8f1f2798 (patch)
tree840008064aacc6764a9992b6f7877e4b3a3ea3d8 /testing/darktable
parent719a3c7e37355444f7722a54d85869ea1c219423 (diff)
downloadaports-838767d46799cd06e0562c1e9bc440ad8f1f2798.tar.bz2
aports-838767d46799cd06e0562c1e9bc440ad8f1f2798.tar.xz
testing/darktable: new package
release candidate with musl support
Diffstat (limited to 'testing/darktable')
-rw-r--r--testing/darktable/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/darktable/APKBUILD b/testing/darktable/APKBUILD
new file mode 100644
index 0000000000..e35127077e
--- /dev/null
+++ b/testing/darktable/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Kevin Daudt <ops@ikke.info>
+# Maintainer: Kevin Daudt <ops@ikke.info>
+_tag=release-2.2.0rc0
+pkgname=darktable
+pkgver=2.2.0_rc0
+pkgrel=0
+pkgdesc="an open source photography workflow application and raw developer"
+url="http://www.darktable.org/"
+arch="all"
+license="GPL3"
+depends="libxslt gtk+3.0-dev libgphoto2-dev libwebp-dev
+ lensfun-dev librsvg-dev sqlite-dev curl-dev jpeg-dev tiff-dev
+ lcms2-dev json-glib-dev exiv2-dev lua5.2-dev pugixml-dev
+ colord-dev colord-gtk-dev openexr-dev"
+makedepends="cmake intltool"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="https://github.com/darktable-org/darktable/archive/$_tag.tar.gz"
+builddir="$srcdir/$pkgname-$_tag"
+
+prepare() {
+ cd "$builddir"
+ mkdir -p build
+}
+
+build() {
+ cd "$builddir/build"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .. || exit 1
+ make
+
+}
+
+package() {
+ cd "$builddir/build"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="d64520874c0c9606849309b4110a5d73 release-2.2.0rc0.tar.gz"
+sha256sums="67cf6f5a460689b7babb65877c5226ef73155d5134e2e4a2c62ad47156ca394d release-2.2.0rc0.tar.gz"
+sha512sums="83efe4414420a19239fafdfb5d7ea8bf1bbf3d6cceae97bd8b9e4e65adce4d420dcf0104ed909904eb6fcd4749d6c8bad9f0951de5b63d7cb4d55f0056e260b3 release-2.2.0rc0.tar.gz"