aboutsummaryrefslogtreecommitdiffstats
path: root/testing/datamash/APKBUILD
diff options
context:
space:
mode:
authorAssaf Gordon <assafgordon@gmail.com>2017-09-03 02:39:38 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-09-06 07:23:43 +0000
commit0b161c7b9b931bd01c3bac181c881433666e62c5 (patch)
tree919fbe319f156d412482dc45b00b8258d03fa894 /testing/datamash/APKBUILD
parent6acb037fe86596a8fabf9dadd94ee936bc861b05 (diff)
downloadaports-0b161c7b9b931bd01c3bac181c881433666e62c5.tar.bz2
aports-0b161c7b9b931bd01c3bac181c881433666e62c5.tar.xz
testing/datamash: new aport
https://www.gnu.org/software/datamash/ GNU Datamash is command-line program which performs basic numeric,textual and statistical operations on input textual data files. Includes 2 sub-packages: datamash-doc (man page + info file) datamash-bash-completion [TT: remove bash-completion.d from main package]
Diffstat (limited to 'testing/datamash/APKBUILD')
-rw-r--r--testing/datamash/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/testing/datamash/APKBUILD b/testing/datamash/APKBUILD
new file mode 100644
index 0000000000..f04438a393
--- /dev/null
+++ b/testing/datamash/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: Assaf Gordon <assafgordon@gmail.com>
+# Maintainer: Assaf Gordon <assafgordon@gmail.com>
+pkgname=datamash
+pkgver=1.2
+pkgrel=0
+
+pkgdesc="command-line text/math procesing"
+url="https://www.gnu.org/software/datamash/"
+arch="all"
+license="GPL"
+source="http://ftpmirror.gnu.org/datamash/$pkgname-$pkgver.tar.gz"
+subpackages="$pkgname-doc $pkgname-bash-completion:bashcomp:noarch"
+
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --disable-nls \
+ --disable-werror \
+ --with-bash-completion-dir=local
+
+ make
+}
+
+package() {
+ cd "$builddir"
+
+ make -j1 DESTDIR="$pkgdir" install
+ rm -rf "$pkgdir"/usr/share/datamash/examples \
+ "$pkgdir"/usr/lib/charset.alias
+}
+
+bashcomp() {
+ depends=""
+ pkgdesc="Bash completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+
+ mkdir -p "$subpkgdir"/usr/share/bash-completion/completions/
+ mv "$pkgdir"/usr/share/datamash/bash-completion.d/datamash \
+ "$subpkgdir"/usr/share/bash-completion/completions/
+ rmdir -p "$pkgdir"/usr/share/datamash/bash-completion.d || true
+}
+
+sha512sums="afb0960ffa881e1112394f5e0355c7a6efea13d6bdcbccb9830a6cde617e13701ca361d62c8283b7a64a27135b2f54a75970b17a7d73a5f0ba914ab70f05c086 datamash-1.2.tar.gz"