aboutsummaryrefslogtreecommitdiffstats
path: root/testing/davfs2
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-10-09 09:15:07 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-10-09 09:15:07 +0000
commit5d25620045e4d0148fae1120f42afb81655cf5bc (patch)
tree3d86b32e3268fd3158029dad32bc3544e64a3eec /testing/davfs2
parent49c32f60818a73963b03f206880023d63dfb44a8 (diff)
downloadaports-5d25620045e4d0148fae1120f42afb81655cf5bc.tar.bz2
aports-5d25620045e4d0148fae1120f42afb81655cf5bc.tar.xz
community/davfs2: move from testing
Diffstat (limited to 'testing/davfs2')
-rw-r--r--testing/davfs2/010-main_code_fix.patch35
-rw-r--r--testing/davfs2/100-musl-compat.patch194
-rw-r--r--testing/davfs2/APKBUILD67
-rwxr-xr-xtesting/davfs2/davfs2.pre-install6
4 files changed, 0 insertions, 302 deletions
diff --git a/testing/davfs2/010-main_code_fix.patch b/testing/davfs2/010-main_code_fix.patch
deleted file mode 100644
index aa36fdfaa7..0000000000
--- a/testing/davfs2/010-main_code_fix.patch
+++ /dev/null
@@ -1,35 +0,0 @@
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -32,8 +32,8 @@ mount_davfs_SOURCES = cache.c dav_coda.c
- kernel_interface.h mount_davfs.h webdav.h
- umount_davfs_SOURCES = umount_davfs.c defaults.h
-
--AM_CFLAGS = -Wall -Werror=format-security \
-- -fstack-protector --param=ssp-buffer-size=4
-+AM_CFLAGS = -Wall -Werror=format-security
-+# -fstack-protector --param=ssp-buffer-size=4 -- removed ssp not supported in openwrt
- DEFS = -DPROGRAM_NAME=\"mount.davfs\" \
- -DDAV_SYS_CONF_DIR=\"$(pkgsysconfdir)\" \
- -DDAV_LOCALSTATE_DIR=\"$(dav_localstatedir)\" \
---- a/src/cache.c
-+++ b/src/cache.c
-@@ -58,7 +58,7 @@
- #ifdef HAVE_SYS_TYPES_H
- #include <sys/types.h>
- #endif
--#include <sys/xattr.h>
-+#include <linux/xattr.h>
-
- #include <ne_alloc.h>
- #include <ne_string.h>
---- a/src/webdav.c
-+++ b/src/webdav.c
-@@ -2033,7 +2033,7 @@ ssl_verify(void *userdata, int failures,
- len = getline(&s, &n, stdin);
- if (len < 0)
- abort();
-- if (rpmatch(s) > 0)
-+ if ((s[0]=='y' || s[0]=='Y') > 0)
- ret = 0;
- free(s);
- }
diff --git a/testing/davfs2/100-musl-compat.patch b/testing/davfs2/100-musl-compat.patch
deleted file mode 100644
index 9663822581..0000000000
--- a/testing/davfs2/100-musl-compat.patch
+++ /dev/null
@@ -1,194 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -42,7 +42,7 @@ DAV_CHECK_NEON
- # Checks for header files.
- AC_HEADER_DIRENT
- AC_HEADER_STDC
--AC_CHECK_HEADERS([fcntl.h libintl.h langinfo.h limits.h locale.h mntent.h stddef.h stdint.h stdlib.h string.h sys/file.h sys/mount.h sys/time.h syslog.h termios.h unistd.h utime.h])
-+AC_CHECK_HEADERS([error.h fcntl.h iconv.h libintl.h langinfo.h limits.h locale.h mntent.h stddef.h stdint.h stdlib.h string.h sys/file.h sys/mount.h sys/time.h sys/select.h sys/types.h syslog.h termios.h unistd.h utime.h])
-
- # Checks for typedefs, structures, and compiler characteristics.
- AC_C_CONST
-@@ -78,7 +78,7 @@ AC_FUNC_SELECT_ARGTYPES
- AC_FUNC_STRFTIME
- AC_FUNC_STAT
- AC_FUNC_UTIME_NULL
--AC_CHECK_FUNCS([endpwent ftruncate getmntent memset mkdir nl_langinfo rpmatch select setlocale strcasecmp strchr strdup strerror strpbrk strrchr strstr strtol strtoull utime])
-+AC_CHECK_FUNCS([endpwent ftruncate getmntent memset mkdir nl_langinfo rpmatch select setlocale strcasecmp strchr strdup strerror strpbrk strrchr strstr strtol strtoull utime canonicalize_file_name fopencookie])
-
- # Misc.
- DAV_DEFAULTS
---- a/src/cache.c
-+++ b/src/cache.c
-@@ -19,12 +19,12 @@
-
-
- #include "config.h"
-+#include "compat.h"
-
- #ifdef HAVE_DIRENT_H
- #include <dirent.h>
- #endif
- #include <errno.h>
--#include <error.h>
- #ifdef HAVE_FCNTL_H
- #include <fcntl.h>
- #endif
---- a/src/dav_fuse.c
-+++ b/src/dav_fuse.c
-@@ -47,6 +47,9 @@
- #ifdef HAVE_SYS_STAT_H
- #include <sys/stat.h>
- #endif
-+#ifdef HAVE_SYS_SELECT_H
-+#include <sys/select.h>
-+#endif
-
- #include "defaults.h"
- #include "mount_davfs.h"
---- a/src/kernel_interface.c
-+++ b/src/kernel_interface.c
-@@ -19,8 +19,8 @@
-
-
- #include "config.h"
-+#include "compat.h"
-
--#include <error.h>
- #ifdef HAVE_FCNTL_H
- #include <fcntl.h>
- #endif
-@@ -51,6 +51,9 @@
- #ifdef HAVE_SYS_STAT_H
- #include <sys/stat.h>
- #endif
-+#ifdef HAVE_SYS_TYPES_H
-+#include <sys/types.h>
-+#endif
- #include <sys/wait.h>
-
- #include "defaults.h"
---- a/src/mount_davfs.c
-+++ b/src/mount_davfs.c
-@@ -19,10 +19,10 @@
-
-
- #include "config.h"
-+#include "compat.h"
-
- #include <ctype.h>
- #include <errno.h>
--#include <error.h>
- #ifdef HAVE_FCNTL_H
- #include <fcntl.h>
- #endif
---- a/src/umount_davfs.c
-+++ b/src/umount_davfs.c
-@@ -19,8 +19,8 @@
-
-
- #include "config.h"
-+#include "compat.h"
-
--#include <error.h>
- #include <errno.h>
- #include <getopt.h>
- #ifdef HAVE_LIBINTL_H
---- a/src/webdav.c
-+++ b/src/webdav.c
-@@ -19,9 +19,9 @@
-
-
- #include "config.h"
-+#include "compat.h"
-
- #include <errno.h>
--#include <error.h>
- #ifdef HAVE_FCNTL_H
- #include <fcntl.h>
- #endif
-@@ -368,6 +368,7 @@ dav_init_webdav(const dav_args *args)
- error(EXIT_FAILURE, errno, _("socket library initialization failed"));
-
- if (args->neon_debug & ~NE_DBG_HTTPPLAIN) {
-+#ifdef HAVE_FOPENCOOKIE
- char *buf = malloc(log_bufsize);
- cookie_io_functions_t *log_func = malloc(sizeof(cookie_io_functions_t));
- if (!log_func) abort();
-@@ -380,6 +381,9 @@ dav_init_webdav(const dav_args *args)
- error(EXIT_FAILURE, errno,
- _("can't open stream to log neon-messages"));
- ne_debug_init(log_stream, args->neon_debug);
-+#else
-+ error(EXIT_FAILURE, 0, "neon debugging unsupported");
-+#endif
- }
-
- session = ne_session_create(args->scheme, args->host, args->port);
---- /dev/null
-+++ b/src/compat.h
-@@ -0,0 +1,64 @@
-+#ifndef _COMPAT_H
-+#define _COMPAT_H
-+
-+#ifndef _PATH_MOUNTED
-+# define _PATH_MOUNTED "/proc/mounts"
-+#endif
-+
-+#ifndef _PATH_MNTTAB
-+# define _PATH_MNTTAB "/etc/fstab"
-+#endif
-+
-+#ifdef HAVE_ERROR_H
-+# include <error.h>
-+#else
-+# include <stdio.h>
-+# include <stdarg.h>
-+# include <stdlib.h>
-+# include <string.h>
-+static void error_at_line(int status, int errnum, const char *filename,
-+ unsigned int linenum, const char *format, ...)
-+{
-+ va_list ap;
-+
-+ fflush(stdout);
-+
-+ if (filename != NULL)
-+ fprintf(stderr, "%s:%u: ", filename, linenum);
-+
-+ va_start(ap, format);
-+ vfprintf(stderr, format, ap);
-+ va_end(ap);
-+
-+ if (errnum != 0)
-+ fprintf(stderr, ": %s", strerror(errnum));
-+
-+ fprintf(stderr, "\n");
-+
-+ if (status != 0)
-+ exit(status);
-+}
-+
-+#define error(status, errnum, format...) \
-+ error_at_line(status, errnum, NULL, 0, format)
-+
-+#endif /* HAVE_ERROR_H */
-+
-+#ifndef HAVE_CANONICALIZE_FILE_NAME
-+#include <limits.h>
-+#include <string.h>
-+#include <stdlib.h>
-+static char * canonicalize_file_name(const char *path)
-+{
-+ char buf[PATH_MAX] = { };
-+
-+ snprintf(buf, sizeof(buf) - 1, "%s", path);
-+
-+ if (!realpath(path, buf))
-+ return NULL;
-+
-+ return strdup(buf);
-+}
-+#endif
-+
-+#endif /* _COMPAT_H */
diff --git a/testing/davfs2/APKBUILD b/testing/davfs2/APKBUILD
deleted file mode 100644
index 293d7ad40d..0000000000
--- a/testing/davfs2/APKBUILD
+++ /dev/null
@@ -1,67 +0,0 @@
-# Contributor: Thomas Harning Jr. <harningt@gmail.com>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=davfs2
-pkgver=1.5.2
-pkgrel=2
-pkgdesc="Linux FUSE (or coda) driver that allows you to mount a WebDAV resource"
-url="http://savannah.nongnu.org/projects/davfs2"
-options="suid"
-pkggroups="davfs2"
-arch="all"
-license="GPL3"
-depends=""
-depends_dev="libxml2-dev neon-dev zlib-dev linux-headers"
-makedepends="$depends_dev autoconf automake libtool"
-install="$pkgname.pre-install"
-subpackages="$pkgname-doc"
-source="http://mirror.lihnidos.org/GNU/savannah/davfs2/${pkgname}-${pkgver}.tar.gz
- 010-main_code_fix.patch
- 100-musl-compat.patch"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
- aclocal -I config \
- && autoheader \
- && automake --add-missing --force-missing --copy \
- && autoconf || return 1
-}
-
-build() {
- cd "$_builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstatedir=/var \
- dav_user=nobody \
- --enable-largefile \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
- install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
- install -o root -g davfs2 -m 1774 -d "$pkgdir"/var/run/mount.davfs
-}
-
-md5sums="376bc9346454135cba78afacbcb23f86 davfs2-1.5.2.tar.gz
-15495a67412345c70e6b211fa8067350 010-main_code_fix.patch
-48ee49fc56364a18f33c5def5b3a859f 100-musl-compat.patch"
-sha256sums="be34a19ab57a6ea77ecb82083e9e4c1882e12b2de64257de567ad5ee7a17b358 davfs2-1.5.2.tar.gz
-e546987cc6083ba2637206aab63e65d054c94bcb315db5ee5bf3774944dd7718 010-main_code_fix.patch
-1ddddfde1110c155b1e0d2756a3310e13a35f6bd6e9a26ac8e3940b2fb5f0d20 100-musl-compat.patch"
-sha512sums="c912049e23b76bda19c2ae2d07bc2b1da7ed9bf82b338c57c0f9fb8a3144cbbb52a0e8f8c2f8996342c7aa434470d062996c30bbbe0f1c6623c81af6414fbb45 davfs2-1.5.2.tar.gz
-99ced4c7183540653b5eb3b9fc6afd06b3d959134c41c2c3a7d65460d6fe9766c9d7f2b774f3064f5e4fd86992fbf500c3e4386a0d814834eb40fb55041bc396 010-main_code_fix.patch
-44ce904db9e4efc48efdb74b791c2a5d135baa1272385906f85ea99fbf3254b010d6d1b4701091f784deebc0d2ebb3ca16a68c768e4af184b2504f31b7a65b3b 100-musl-compat.patch"
diff --git a/testing/davfs2/davfs2.pre-install b/testing/davfs2/davfs2.pre-install
deleted file mode 100755
index 062477c7fd..0000000000
--- a/testing/davfs2/davfs2.pre-install
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-
-if ! getent group davfs2 >/dev/null; then
- addgroup -S davfs2
-fi
-exit 0