aboutsummaryrefslogtreecommitdiffstats
path: root/testing/davfs2
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /testing/davfs2
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'testing/davfs2')
-rw-r--r--testing/davfs2/010-main_code_fix.patch35
-rw-r--r--testing/davfs2/100-musl-compat.patch194
-rw-r--r--testing/davfs2/APKBUILD61
3 files changed, 0 insertions, 290 deletions
diff --git a/testing/davfs2/010-main_code_fix.patch b/testing/davfs2/010-main_code_fix.patch
deleted file mode 100644
index aa36fdfaa7..0000000000
--- a/testing/davfs2/010-main_code_fix.patch
+++ /dev/null
@@ -1,35 +0,0 @@
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -32,8 +32,8 @@ mount_davfs_SOURCES = cache.c dav_coda.c
- kernel_interface.h mount_davfs.h webdav.h
- umount_davfs_SOURCES = umount_davfs.c defaults.h
-
--AM_CFLAGS = -Wall -Werror=format-security \
-- -fstack-protector --param=ssp-buffer-size=4
-+AM_CFLAGS = -Wall -Werror=format-security
-+# -fstack-protector --param=ssp-buffer-size=4 -- removed ssp not supported in openwrt
- DEFS = -DPROGRAM_NAME=\"mount.davfs\" \
- -DDAV_SYS_CONF_DIR=\"$(pkgsysconfdir)\" \
- -DDAV_LOCALSTATE_DIR=\"$(dav_localstatedir)\" \
---- a/src/cache.c
-+++ b/src/cache.c
-@@ -58,7 +58,7 @@
- #ifdef HAVE_SYS_TYPES_H
- #include <sys/types.h>
- #endif
--#include <sys/xattr.h>
-+#include <linux/xattr.h>
-
- #include <ne_alloc.h>
- #include <ne_string.h>
---- a/src/webdav.c
-+++ b/src/webdav.c
-@@ -2033,7 +2033,7 @@ ssl_verify(void *userdata, int failures,
- len = getline(&s, &n, stdin);
- if (len < 0)
- abort();
-- if (rpmatch(s) > 0)
-+ if ((s[0]=='y' || s[0]=='Y') > 0)
- ret = 0;
- free(s);
- }
diff --git a/testing/davfs2/100-musl-compat.patch b/testing/davfs2/100-musl-compat.patch
deleted file mode 100644
index 9663822581..0000000000
--- a/testing/davfs2/100-musl-compat.patch
+++ /dev/null
@@ -1,194 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -42,7 +42,7 @@ DAV_CHECK_NEON
- # Checks for header files.
- AC_HEADER_DIRENT
- AC_HEADER_STDC
--AC_CHECK_HEADERS([fcntl.h libintl.h langinfo.h limits.h locale.h mntent.h stddef.h stdint.h stdlib.h string.h sys/file.h sys/mount.h sys/time.h syslog.h termios.h unistd.h utime.h])
-+AC_CHECK_HEADERS([error.h fcntl.h iconv.h libintl.h langinfo.h limits.h locale.h mntent.h stddef.h stdint.h stdlib.h string.h sys/file.h sys/mount.h sys/time.h sys/select.h sys/types.h syslog.h termios.h unistd.h utime.h])
-
- # Checks for typedefs, structures, and compiler characteristics.
- AC_C_CONST
-@@ -78,7 +78,7 @@ AC_FUNC_SELECT_ARGTYPES
- AC_FUNC_STRFTIME
- AC_FUNC_STAT
- AC_FUNC_UTIME_NULL
--AC_CHECK_FUNCS([endpwent ftruncate getmntent memset mkdir nl_langinfo rpmatch select setlocale strcasecmp strchr strdup strerror strpbrk strrchr strstr strtol strtoull utime])
-+AC_CHECK_FUNCS([endpwent ftruncate getmntent memset mkdir nl_langinfo rpmatch select setlocale strcasecmp strchr strdup strerror strpbrk strrchr strstr strtol strtoull utime canonicalize_file_name fopencookie])
-
- # Misc.
- DAV_DEFAULTS
---- a/src/cache.c
-+++ b/src/cache.c
-@@ -19,12 +19,12 @@
-
-
- #include "config.h"
-+#include "compat.h"
-
- #ifdef HAVE_DIRENT_H
- #include <dirent.h>
- #endif
- #include <errno.h>
--#include <error.h>
- #ifdef HAVE_FCNTL_H
- #include <fcntl.h>
- #endif
---- a/src/dav_fuse.c
-+++ b/src/dav_fuse.c
-@@ -47,6 +47,9 @@
- #ifdef HAVE_SYS_STAT_H
- #include <sys/stat.h>
- #endif
-+#ifdef HAVE_SYS_SELECT_H
-+#include <sys/select.h>
-+#endif
-
- #include "defaults.h"
- #include "mount_davfs.h"
---- a/src/kernel_interface.c
-+++ b/src/kernel_interface.c
-@@ -19,8 +19,8 @@
-
-
- #include "config.h"
-+#include "compat.h"
-
--#include <error.h>
- #ifdef HAVE_FCNTL_H
- #include <fcntl.h>
- #endif
-@@ -51,6 +51,9 @@
- #ifdef HAVE_SYS_STAT_H
- #include <sys/stat.h>
- #endif
-+#ifdef HAVE_SYS_TYPES_H
-+#include <sys/types.h>
-+#endif
- #include <sys/wait.h>
-
- #include "defaults.h"
---- a/src/mount_davfs.c
-+++ b/src/mount_davfs.c
-@@ -19,10 +19,10 @@
-
-
- #include "config.h"
-+#include "compat.h"
-
- #include <ctype.h>
- #include <errno.h>
--#include <error.h>
- #ifdef HAVE_FCNTL_H
- #include <fcntl.h>
- #endif
---- a/src/umount_davfs.c
-+++ b/src/umount_davfs.c
-@@ -19,8 +19,8 @@
-
-
- #include "config.h"
-+#include "compat.h"
-
--#include <error.h>
- #include <errno.h>
- #include <getopt.h>
- #ifdef HAVE_LIBINTL_H
---- a/src/webdav.c
-+++ b/src/webdav.c
-@@ -19,9 +19,9 @@
-
-
- #include "config.h"
-+#include "compat.h"
-
- #include <errno.h>
--#include <error.h>
- #ifdef HAVE_FCNTL_H
- #include <fcntl.h>
- #endif
-@@ -368,6 +368,7 @@ dav_init_webdav(const dav_args *args)
- error(EXIT_FAILURE, errno, _("socket library initialization failed"));
-
- if (args->neon_debug & ~NE_DBG_HTTPPLAIN) {
-+#ifdef HAVE_FOPENCOOKIE
- char *buf = malloc(log_bufsize);
- cookie_io_functions_t *log_func = malloc(sizeof(cookie_io_functions_t));
- if (!log_func) abort();
-@@ -380,6 +381,9 @@ dav_init_webdav(const dav_args *args)
- error(EXIT_FAILURE, errno,
- _("can't open stream to log neon-messages"));
- ne_debug_init(log_stream, args->neon_debug);
-+#else
-+ error(EXIT_FAILURE, 0, "neon debugging unsupported");
-+#endif
- }
-
- session = ne_session_create(args->scheme, args->host, args->port);
---- /dev/null
-+++ b/src/compat.h
-@@ -0,0 +1,64 @@
-+#ifndef _COMPAT_H
-+#define _COMPAT_H
-+
-+#ifndef _PATH_MOUNTED
-+# define _PATH_MOUNTED "/proc/mounts"
-+#endif
-+
-+#ifndef _PATH_MNTTAB
-+# define _PATH_MNTTAB "/etc/fstab"
-+#endif
-+
-+#ifdef HAVE_ERROR_H
-+# include <error.h>
-+#else
-+# include <stdio.h>
-+# include <stdarg.h>
-+# include <stdlib.h>
-+# include <string.h>
-+static void error_at_line(int status, int errnum, const char *filename,
-+ unsigned int linenum, const char *format, ...)
-+{
-+ va_list ap;
-+
-+ fflush(stdout);
-+
-+ if (filename != NULL)
-+ fprintf(stderr, "%s:%u: ", filename, linenum);
-+
-+ va_start(ap, format);
-+ vfprintf(stderr, format, ap);
-+ va_end(ap);
-+
-+ if (errnum != 0)
-+ fprintf(stderr, ": %s", strerror(errnum));
-+
-+ fprintf(stderr, "\n");
-+
-+ if (status != 0)
-+ exit(status);
-+}
-+
-+#define error(status, errnum, format...) \
-+ error_at_line(status, errnum, NULL, 0, format)
-+
-+#endif /* HAVE_ERROR_H */
-+
-+#ifndef HAVE_CANONICALIZE_FILE_NAME
-+#include <limits.h>
-+#include <string.h>
-+#include <stdlib.h>
-+static char * canonicalize_file_name(const char *path)
-+{
-+ char buf[PATH_MAX] = { };
-+
-+ snprintf(buf, sizeof(buf) - 1, "%s", path);
-+
-+ if (!realpath(path, buf))
-+ return NULL;
-+
-+ return strdup(buf);
-+}
-+#endif
-+
-+#endif /* _COMPAT_H */
diff --git a/testing/davfs2/APKBUILD b/testing/davfs2/APKBUILD
deleted file mode 100644
index 46dd49288d..0000000000
--- a/testing/davfs2/APKBUILD
+++ /dev/null
@@ -1,61 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer:
-pkgname=davfs2
-pkgver=1.5.2
-pkgrel=0
-pkgdesc="File system driver that allows you to mount a WebDAV folder"
-url="http://savannah.nongnu.org/projects/davfs2"
-arch="all"
-license="GPL"
-depends=""
-depends_dev=""
-makedepends="$depends_dev neon-dev linux-headers autoconf automake libtool
- gettext-dev"
-install=""
-options="suid"
-subpackages="$pkgname-doc"
-source="http://download.savannah.gnu.org/releases/davfs2/davfs2-$pkgver.tar.gz
- 010-main_code_fix.patch
- 100-musl-compat.patch
- "
-
-_builddir="$srcdir"/davfs2-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- autoreconf -fi || return 1
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstatedir=/var \
- --disable-nls \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
- rm -f "$pkgdir"/usr/lib/*.la
-}
-
-md5sums="376bc9346454135cba78afacbcb23f86 davfs2-1.5.2.tar.gz
-15495a67412345c70e6b211fa8067350 010-main_code_fix.patch
-48ee49fc56364a18f33c5def5b3a859f 100-musl-compat.patch"
-sha256sums="be34a19ab57a6ea77ecb82083e9e4c1882e12b2de64257de567ad5ee7a17b358 davfs2-1.5.2.tar.gz
-e546987cc6083ba2637206aab63e65d054c94bcb315db5ee5bf3774944dd7718 010-main_code_fix.patch
-1ddddfde1110c155b1e0d2756a3310e13a35f6bd6e9a26ac8e3940b2fb5f0d20 100-musl-compat.patch"
-sha512sums="c912049e23b76bda19c2ae2d07bc2b1da7ed9bf82b338c57c0f9fb8a3144cbbb52a0e8f8c2f8996342c7aa434470d062996c30bbbe0f1c6623c81af6414fbb45 davfs2-1.5.2.tar.gz
-99ced4c7183540653b5eb3b9fc6afd06b3d959134c41c2c3a7d65460d6fe9766c9d7f2b774f3064f5e4fd86992fbf500c3e4386a0d814834eb40fb55041bc396 010-main_code_fix.patch
-44ce904db9e4efc48efdb74b791c2a5d135baa1272385906f85ea99fbf3254b010d6d1b4701091f784deebc0d2ebb3ca16a68c768e4af184b2504f31b7a65b3b 100-musl-compat.patch"