aboutsummaryrefslogtreecommitdiffstats
path: root/testing/dcontainers
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-02-29 23:49:53 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-03-01 11:24:34 +0100
commit36c8bcfb9d3f64179d563f032b0c68b1317d0dc1 (patch)
tree704fd279b2a0e1da290647a3d2502e2dfa4bd3ab /testing/dcontainers
parent246e3c42d90c60cac249e414ee19935da696c88b (diff)
downloadaports-36c8bcfb9d3f64179d563f032b0c68b1317d0dc1.tar.bz2
aports-36c8bcfb9d3f64179d563f032b0c68b1317d0dc1.tar.xz
testing/dcontainers: new aport
https://github.com/dlang-community/containers Containers backed by std.experimental.allocator
Diffstat (limited to 'testing/dcontainers')
-rw-r--r--testing/dcontainers/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/dcontainers/APKBUILD b/testing/dcontainers/APKBUILD
new file mode 100644
index 0000000000..5c7a25703f
--- /dev/null
+++ b/testing/dcontainers/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=dcontainers
+pkgver=0.8.0_alpha19
+_alphanum=${pkgver/${pkgver%alpha*}/}
+_pkgver=${pkgver/_$_alphanum/}
+_verstring=$_pkgver-${_alphanum/ha/ha.}
+pkgrel=0
+pkgdesc="Containers backed by std.experimental.allocator"
+url="https://github.com/dlang-community/containers"
+arch="x86_64" # ldc
+license="BSL-1.0"
+makedepends="meson ldc ldc-runtime stdx-allocator-dev"
+subpackages="$pkgname-dev"
+source="https://github.com/dlang-community/containers/archive/v$_verstring/containers-$_verstring.tar.gz"
+builddir="$srcdir/containers-$_verstring"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=plain \
+ . output
+ ninja -C output
+}
+
+check() {
+ ninja -C output test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="ef415e2bf7829e05c458cee0e41b6fc5768805a8dee332fb6a01a72e1e723f240f183cd1fd5ed74848cc4ea860b0746dca1c5dee13d37f819f0025da99098c4a containers-0.8.0-alpha.19.tar.gz"