aboutsummaryrefslogtreecommitdiffstats
path: root/testing/dcron/ldflags.patch
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2015-09-28 15:54:39 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2015-09-28 15:54:39 +0200
commitc87453388fd46eaa8db5bad0b17632383567c359 (patch)
treef035a48222d02ffae5c8f785fa8a190b4c9360b4 /testing/dcron/ldflags.patch
parent41d8142af0dc8fbf10385b5bd80fb3b6c8813800 (diff)
downloadaports-c87453388fd46eaa8db5bad0b17632383567c359.tar.bz2
aports-c87453388fd46eaa8db5bad0b17632383567c359.tar.xz
testing/dcron: new aport
Diffstat (limited to 'testing/dcron/ldflags.patch')
-rw-r--r--testing/dcron/ldflags.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/dcron/ldflags.patch b/testing/dcron/ldflags.patch
new file mode 100644
index 0000000000..7fa2d8d9d0
--- /dev/null
+++ b/testing/dcron/ldflags.patch
@@ -0,0 +1,38 @@
+From 8a292168e584c50808b80df3577a7d89fa32db26 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Mon, 16 May 2011 16:24:20 -0400
+Subject: [PATCH] drop LDFLAGS set, and restore CFLAGS linking
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ Makefile | 5 ++---
+ 1 files changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 1938e05..8309ad6 100644
+--- a/Makefile
++++ b/Makefile
+@@ -32,7 +32,6 @@ TABSRCS = crontab.c chuser.c
+ TABOBJS = crontab.o chuser.o
+ PROTOS = protos.h
+ LIBS =
+-LDFLAGS =
+ DEFS = -DVERSION='"$(VERSION)"' \
+ -DSCRONTABS='"$(SCRONTABS)"' -DCRONTABS='"$(CRONTABS)"' \
+ -DCRONSTAMPS='"$(CRONSTAMPS)"' -DLOG_IDENT='"$(LOG_IDENT)"' \
+@@ -54,10 +53,10 @@ protos.h: $(SRCS) $(TABSRCS)
+ fgrep -h Prototype $(SRCS) $(TABSRCS) > protos.h
+
+ crond: $(OBJS)
+- $(CC) $(LDFLAGS) $^ $(LIBS) -o crond
++ $(CC) $(CFLAGS) $(LDFLAGS) $^ $(LIBS) -o crond
+
+ crontab: $(TABOBJS)
+- $(CC) $(LDFLAGS) $^ -o crontab
++ $(CC) $(CFLAGS) $(LDFLAGS) $^ -o crontab
+
+ %.o: %.c defs.h $(PROTOS)
+ $(CC) $(CFLAGS) $(CPPFLAGS) -c $(DEFS) $< -o $@
+--
+1.7.5.rc3
+