aboutsummaryrefslogtreecommitdiffstats
path: root/testing/deluge
diff options
context:
space:
mode:
authorWeilu Jia <optix2000@teitoku.net>2020-03-18 01:53:20 -0700
committerRasmus Thomsen <oss@cogitri.dev>2020-03-19 20:24:59 +0000
commit3fedbb545c8e01ea977ae771114aacf05c931df6 (patch)
tree69e927c86ad023e038a1e20e9f40a0a89a5e5285 /testing/deluge
parent20721184752d5a64fab6b3b5f94d21d9504c7662 (diff)
downloadaports-3fedbb545c8e01ea977ae771114aacf05c931df6.tar.bz2
aports-3fedbb545c8e01ea977ae771114aacf05c931df6.tar.xz
testing/deluge: Fix logging on Python 3.8
Closes https://gitlab.alpinelinux.org/alpine/aports/issues/11313 Backport patch from https://dev.deluge-torrent.org/ticket/3327
Diffstat (limited to 'testing/deluge')
-rw-r--r--testing/deluge/10-python38-logging.patch15
-rw-r--r--testing/deluge/APKBUILD9
2 files changed, 21 insertions, 3 deletions
diff --git a/testing/deluge/10-python38-logging.patch b/testing/deluge/10-python38-logging.patch
new file mode 100644
index 0000000000..a3c9ad4e99
--- /dev/null
+++ b/testing/deluge/10-python38-logging.patch
@@ -0,0 +1,15 @@
+https://dev.deluge-torrent.org/changeset/351664ec071daa04
+Slated for 2.0.4 release
+diff --git a/deluge/log.py b/deluge/log.py
+index 75e8308b5..0f9877fdb 100644
+--- a/deluge/log.py
++++ b/deluge/log.py
+@@ -86,7 +86,7 @@ def critical(self, msg, *args, **kwargs):
+ def exception(self, msg, *args, **kwargs):
+ yield LoggingLoggerClass.exception(self, msg, *args, **kwargs)
+
+- def findCaller(self, stack_info=False): # NOQA: N802
++ def findCaller(self, *args, **kwargs): # NOQA: N802
+ f = logging.currentframe().f_back
+ rv = '(unknown file)', 0, '(unknown function)'
+ while hasattr(f, 'f_code'):
diff --git a/testing/deluge/APKBUILD b/testing/deluge/APKBUILD
index bee14dc22d..9ba046214a 100644
--- a/testing/deluge/APKBUILD
+++ b/testing/deluge/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: August Klein <amatcoder@gmail.com>
pkgname=deluge
pkgver=2.0.3
-pkgrel=4
+pkgrel=5
pkgdesc="A lightweight, Free Software, cross-platform BitTorrent client"
url="https://deluge-torrent.org/"
arch="noarch"
@@ -32,7 +32,9 @@ depends="
py3-wheel
"
subpackages="$pkgname-doc"
-source="http://download.deluge-torrent.org/source/${pkgver%.*}/deluge-$pkgver.tar.xz"
+source="http://download.deluge-torrent.org/source/${pkgver%.*}/deluge-$pkgver.tar.xz
+ 10-python38-logging.patch
+ "
replaces="$pkgname-lang" # Overwrite removed subpackage
@@ -44,4 +46,5 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="3abec24495b22ec10649865c7ce7c3271224c7d25c0647b43f3c177b7ccb45d4c5c593f8c89d8bc8eac85ae5dc737f9960827587912dd527bb96100304a7d480 deluge-2.0.3.tar.xz"
+sha512sums="3abec24495b22ec10649865c7ce7c3271224c7d25c0647b43f3c177b7ccb45d4c5c593f8c89d8bc8eac85ae5dc737f9960827587912dd527bb96100304a7d480 deluge-2.0.3.tar.xz
+8ab11f87ddf62a7cba2d2783eec2c439fdc416e5d165ac6b510a9818c28573df32ef408bb16ca61d93b27bb5090782f5b4005a4ad50cfa9fa6dfb869aa2be57c 10-python38-logging.patch"