aboutsummaryrefslogtreecommitdiffstats
path: root/testing/deluge
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-07-28 13:34:02 +0300
committerNatanael Copa <ncopa@alpinelinux.org>2018-08-31 06:14:41 +0000
commitaedf6f6f2c2ac98862dce366d89e7c49ed350ffa (patch)
tree3f22f5fea2b4f9f69b32f17177d942339bb7d8c0 /testing/deluge
parentaa1436746002630b342b52f0feffa416500abcb3 (diff)
downloadaports-aedf6f6f2c2ac98862dce366d89e7c49ed350ffa.tar.bz2
aports-aedf6f6f2c2ac98862dce366d89e7c49ed350ffa.tar.xz
testing/deluge: use https, modernize
Diffstat (limited to 'testing/deluge')
-rw-r--r--testing/deluge/APKBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/testing/deluge/APKBUILD b/testing/deluge/APKBUILD
index 5786a700c0..7e096b3891 100644
--- a/testing/deluge/APKBUILD
+++ b/testing/deluge/APKBUILD
@@ -2,9 +2,9 @@
# Maintainer: August Klein <amatcoder@gmail.com>
pkgname=deluge
pkgver=1.3.15
-pkgrel=1
+pkgrel=2
pkgdesc="A lightweight, Free Software, cross-platform BitTorrent client"
-url="http://deluge-torrent.org"
+url="https://deluge-torrent.org"
arch="noarch"
license="GPL-3.0"
depends="libtorrent-rasterbar librsvg py-cffi py-chardet py-cryptography
@@ -12,24 +12,24 @@ depends="libtorrent-rasterbar librsvg py-cffi py-chardet py-cryptography
py-xdg xdg-utils"
makedepends="intltool librsvg-dev py-gtk-dev py-mako py-setuptools"
subpackages="$pkgname-lang $pkgname-doc"
-source="http://download.deluge-torrent.org/source/$pkgname-$pkgver.tar.bz2"
+source="https://download.deluge-torrent.org/source/$pkgname-$pkgver.tar.bz2"
builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
- python2 setup.py build || return 1
+ python2 setup.py build
}
package() {
cd "$builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
}
lang() {
- mkdir -p "$subpkgdir"/usr/lib/python2.7/site-packages/deluge/i18n || return 1
+ mkdir -p "$subpkgdir"/usr/lib/python2.7/site-packages/deluge/i18n
mv "$pkgdir"/usr/lib/python2.7/site-packages/deluge/i18n/* \
- "$subpkgdir"/usr/lib/python2.7/site-packages/deluge/i18n/ || return 1
+ "$subpkgdir"/usr/lib/python2.7/site-packages/deluge/i18n/
}
sha512sums="1d0f93a8c5081b807a390f79101d7f26751b0dfc47efe4c3573541014f9e5969461e2d421d17646c17fb81eb4f66f25f5ddce63b9bd226989adb7d7506146bda deluge-1.3.15.tar.bz2"