aboutsummaryrefslogtreecommitdiffstats
path: root/testing/devicemaster-linux-grsec
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-12-25 07:56:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-12-25 07:57:32 +0000
commitd8cbe7f15cd48739be1c724d06b765567d262f36 (patch)
tree09ab2acc755eb2eb246b25111e3a4af59546891f /testing/devicemaster-linux-grsec
parented592d250d4b1ef7fce859bb1e944bb66b8c3e01 (diff)
downloadaports-d8cbe7f15cd48739be1c724d06b765567d262f36.tar.bz2
aports-d8cbe7f15cd48739be1c724d06b765567d262f36.tar.xz
testing/devicemaster-linux-grsec: rebuild against kernel 3.14.27-r0
Diffstat (limited to 'testing/devicemaster-linux-grsec')
-rw-r--r--testing/devicemaster-linux-grsec/APKBUILD12
-rw-r--r--testing/devicemaster-linux-grsec/nslink.patch42
2 files changed, 41 insertions, 13 deletions
diff --git a/testing/devicemaster-linux-grsec/APKBUILD b/testing/devicemaster-linux-grsec/APKBUILD
index 719262af13..dbb4ead11e 100644
--- a/testing/devicemaster-linux-grsec/APKBUILD
+++ b/testing/devicemaster-linux-grsec/APKBUILD
@@ -2,7 +2,7 @@
_flavor=grsec
_kpkg=linux-$_flavor
-_kver=3.14.26
+_kver=3.14.27
_kpkgrel=0
_mypkgrel=0
@@ -20,7 +20,7 @@ url="http://www.comtrol.com/resources/product-resources-white-papers/ns-link-dev
arch="all"
license="GPL"
depends="linux-${_flavor}=${_kpkgver}"
-makedepends="linux-${_flavor}-dev=${_kpkgver}"
+makedepends="linux-${_flavor}-dev=${_kpkgver} linux-headers"
install=
install_if="$_kpkg=$_kpkgver $_realname"
subpackages=""
@@ -54,7 +54,7 @@ prepare() {
build() {
cd "$srcdir/$_realname-$_realver"
make -C /lib/modules/$_abi_release/build SUBDIRS="$PWD" modules \
- || return 1
+ V=1 || return 1
}
package() {
@@ -64,8 +64,8 @@ package() {
}
md5sums="deded30023c8135c9beb06696e8c578f devicemaster-linux-7.06.tar.gz
-a15ebdcb005256e223febe1d2dba42b6 nslink.patch"
+4a7ab12e64cfb0dc2f5270a95534ca18 nslink.patch"
sha256sums="6b11295952d1d74a6102a295a6ed5651ec040a0d8c30838cd23a1f3f7c95a4e7 devicemaster-linux-7.06.tar.gz
-60c0106d23126ed8053b46547eed030414cadac940e2b69f76cfc3e74575a1e1 nslink.patch"
+6d635a133f795a90ff776b1f5026d4cae734570a46042b3e23c3f6bd07d2c11c nslink.patch"
sha512sums="496144ee40464c96442ce655424db886cb5b4df1701e30cc8d059fc918e8916cb6c3b0b57cead2d0e9d50e4618ee13efa5f3630765545ea45e29f8080101800b devicemaster-linux-7.06.tar.gz
-7fe4e5482cd5900e0795bf4a5cb52924453fa21e2b94ffabe5f53dc61fc421e7e96cd5df241721a122c5b01c0ef159aa6082d6f2e93329012ebcf63a55c32825 nslink.patch"
+acb1e19bb56f47ba95bebf386c66a5639e11ed5c3d7e8591060fcc739d5383cec0cab08a1accaeef930adae495f3a63526ed1491977567caa257e4a9bd219045 nslink.patch"
diff --git a/testing/devicemaster-linux-grsec/nslink.patch b/testing/devicemaster-linux-grsec/nslink.patch
index c9ff480861..0304bf6c8b 100644
--- a/testing/devicemaster-linux-grsec/nslink.patch
+++ b/testing/devicemaster-linux-grsec/nslink.patch
@@ -1,6 +1,16 @@
---- ./nslink.c.orig
-+++ ./nslink.c
-@@ -2864,7 +2864,7 @@
+diff --git a/nslink.c b/nslink.c
+index 16a4212..e64907d 100755
+--- a/nslink.c
++++ b/nslink.c
+@@ -113,6 +113,7 @@
+ #include <linux/slab.h>
+ #include <linux/time.h>
+ #include <linux/delay.h>
++#include <linux/utsname.h>
+ #if LINUX_VERSION_CODE >= VERSION_CODE(2,6,36) && LINUX_VERSION_CODE < VERSION_CODE(2,6,39)
+ #include <linux/smp_lock.h>
+ #endif
+@@ -2864,7 +2865,7 @@ static int nrp_open(struct tty_struct *tty, struct file *filp)
info = nrp_table[line];
@@ -9,7 +19,7 @@
if (!info->si) {
DebugOpenErr("ttySI%d info->si==NULL: return -ENODEV\n", line);
-@@ -2880,9 +2880,9 @@
+@@ -2880,9 +2881,9 @@ static int nrp_open(struct tty_struct *tty, struct file *filp)
ret = tty_port_open(&info->port, tty, filp);
if (ret && ret != -ERESTARTSYS)
@@ -21,7 +31,7 @@
return ret;
}
-@@ -2925,9 +2925,9 @@
+@@ -2925,9 +2926,9 @@ static void nrp_port_shutdown(struct tty_port *port)
static void nrp_close(struct tty_struct *tty, struct file *filp)
{
struct nr_port *info = (struct nr_port *) tty->driver_data;
@@ -33,7 +43,7 @@
}
static void nrp_set_termios(struct tty_struct *tty, struct ktermios *old_termios)
-@@ -4786,7 +4786,7 @@
+@@ -4786,7 +4787,7 @@ static int free_si_box(int boxid)
info = nrp_table[i + si->base_port];
if (!info)
continue;
@@ -42,7 +52,7 @@
DebugOpenErr("Attempt to free_si_box() with port open\n");
return -EBUSY;
}
-@@ -5008,7 +5008,7 @@
+@@ -5008,7 +5009,7 @@ static int port_proc_show(struct seq_file *m, void *v)
for (i=0; i<NumElements(nrp_table); ++i) {
struct nr_port *info = nrp_table[i];
if (info) {
@@ -51,3 +61,21 @@
// Ctrl ...
seq_printf(m, (info->control_settings & SC_DATABITS_7) ? "7" : "8");
+@@ -5192,7 +5193,7 @@ static int status_proc_show(struct seq_file *m, void *v)
+ struct si_state *si;
+
+ seq_printf(m, "Comtrol NS-Link -- version %s (%s)\n",SI_VERSION,SI_DATE);
+- seq_printf(m, "Built %s %s\n\n",__DATE__,__TIME__);
++ seq_printf(m, "Build %s\n\n",utsname()->version);
+ seq_printf(m, "Hub State Address Ports\n");
+ seq_printf(m, "--- ------------ ------------------ -----\n");
+
+@@ -5381,7 +5382,7 @@ int nrp_init(void)
+ static struct proc_dir_entry *procdir;
+
+ printk(KERN_INFO "nslink: NS-Link driver, version %s %s\n",SI_VERSION, SI_DATE);
+- printk(KERN_INFO "nslink: Built %s %s\n", __DATE__, __TIME__);
++ printk(KERN_INFO "nslink: Build %s\n", utsname()->version);
+
+ // Initialize the array of pointers to our own internal state structures.
+ memset(nrp_table, 0, sizeof(nrp_table));