aboutsummaryrefslogtreecommitdiffstats
path: root/testing/diffoscope/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-12-17 08:37:36 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-12-17 08:38:10 +0000
commit3a02b79036e7b179363ad559d8b3479a26611cc7 (patch)
tree7d8d6acdbe499c581219aa9bb42c3f10e119cc6d /testing/diffoscope/APKBUILD
parent4012551bbe15f0d1be8e9432e0f3955f715cf5ea (diff)
downloadaports-3a02b79036e7b179363ad559d8b3479a26611cc7.tar.bz2
aports-3a02b79036e7b179363ad559d8b3479a26611cc7.tar.xz
testing/diffoscope: new apkbuild
In-depth comparison of files, archives, and directories https://diffoscope.org/
Diffstat (limited to 'testing/diffoscope/APKBUILD')
-rw-r--r--testing/diffoscope/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/diffoscope/APKBUILD b/testing/diffoscope/APKBUILD
new file mode 100644
index 0000000000..b5baeec713
--- /dev/null
+++ b/testing/diffoscope/APKBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=diffoscope
+pkgver=105
+pkgrel=0
+pkgdesc="In-depth comparison of files, archives, and directories"
+url="https://diffoscope.org/"
+arch="all"
+license="GPL-3.0-or-later"
+makedepends="python3-dev py3-setuptools py3-docutils"
+depends="py3-magic py3-libarchive-c"
+subpackages=""
+checkdepends="py3-pytest gzip bzip2 unzip libarchive-tools"
+source="https://salsa.debian.org/reproducible-builds/diffoscope/-/archive/$pkgver/diffoscope-$pkgver.tar.gz
+ mozillazip.patch
+ "
+builddir="$srcdir/diffoscope-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py test
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="16ec3e0cdc834edcfebb0cf9087648dcd86bd605c4522334f3ad31c3f4866c277da082b278cc88942678cd59012a23e3c3136414dd7dcd854a9e4e04ac234c63 diffoscope-105.tar.gz
+2b57f3fd21023e5770ef4479eda5048880f39da7aa0814f2c2c062cf0d8a3d263da0f131ad8b578e707b97db1fa5bea1019143cf1ff1296f54bef558c2d28399 mozillazip.patch"