aboutsummaryrefslogtreecommitdiffstats
path: root/testing/diffoscope
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-12-17 08:37:36 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-12-17 08:38:10 +0000
commit3a02b79036e7b179363ad559d8b3479a26611cc7 (patch)
tree7d8d6acdbe499c581219aa9bb42c3f10e119cc6d /testing/diffoscope
parent4012551bbe15f0d1be8e9432e0f3955f715cf5ea (diff)
downloadaports-3a02b79036e7b179363ad559d8b3479a26611cc7.tar.bz2
aports-3a02b79036e7b179363ad559d8b3479a26611cc7.tar.xz
testing/diffoscope: new apkbuild
In-depth comparison of files, archives, and directories https://diffoscope.org/
Diffstat (limited to 'testing/diffoscope')
-rw-r--r--testing/diffoscope/APKBUILD34
-rw-r--r--testing/diffoscope/mozillazip.patch60
2 files changed, 94 insertions, 0 deletions
diff --git a/testing/diffoscope/APKBUILD b/testing/diffoscope/APKBUILD
new file mode 100644
index 0000000000..b5baeec713
--- /dev/null
+++ b/testing/diffoscope/APKBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=diffoscope
+pkgver=105
+pkgrel=0
+pkgdesc="In-depth comparison of files, archives, and directories"
+url="https://diffoscope.org/"
+arch="all"
+license="GPL-3.0-or-later"
+makedepends="python3-dev py3-setuptools py3-docutils"
+depends="py3-magic py3-libarchive-c"
+subpackages=""
+checkdepends="py3-pytest gzip bzip2 unzip libarchive-tools"
+source="https://salsa.debian.org/reproducible-builds/diffoscope/-/archive/$pkgver/diffoscope-$pkgver.tar.gz
+ mozillazip.patch
+ "
+builddir="$srcdir/diffoscope-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py test
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="16ec3e0cdc834edcfebb0cf9087648dcd86bd605c4522334f3ad31c3f4866c277da082b278cc88942678cd59012a23e3c3136414dd7dcd854a9e4e04ac234c63 diffoscope-105.tar.gz
+2b57f3fd21023e5770ef4479eda5048880f39da7aa0814f2c2c062cf0d8a3d263da0f131ad8b578e707b97db1fa5bea1019143cf1ff1296f54bef558c2d28399 mozillazip.patch"
diff --git a/testing/diffoscope/mozillazip.patch b/testing/diffoscope/mozillazip.patch
new file mode 100644
index 0000000000..bfaf4b5b72
--- /dev/null
+++ b/testing/diffoscope/mozillazip.patch
@@ -0,0 +1,60 @@
+From a069181d747d3ff9e034031ec2bdf5d119e41a34 Mon Sep 17 00:00:00 2001
+From: Mattia Rizzolo <mattia@debian.org>
+Date: Thu, 13 Dec 2018 15:22:31 +0100
+Subject: [PATCH] comparators: try matching for MozillaZipFile before ZipFile
+
+Fixes a test failure in Alpine Linux.
+
+Signed-off-by: Mattia Rizzolo <mattia@debian.org>
+---
+ diffoscope/comparators/__init__.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/diffoscope/comparators/__init__.py b/diffoscope/comparators/__init__.py
+index cc33a26..71f9861 100644
+--- a/diffoscope/comparators/__init__.py
++++ b/diffoscope/comparators/__init__.py
+@@ -85,8 +85,8 @@ class ComparatorManager(object):
+ ('odt.OdtFile',),
+ ('ocaml.OcamlInterfaceFile',),
+ ('docx.DocxFile',),
+- ('zip.ZipFile',),
+ ('zip.MozillaZipFile',),
++ ('zip.ZipFile',),
+ ('image.JPEGImageFile',),
+ ('image.ICOImageFile',),
+ ('cbfs.CbfsFile',),
+--
+2.19.2
+
+From 5f50be792e0fed289c4470fc668ebb613723cb89 Mon Sep 17 00:00:00 2001
+From: Chris Lamb <lamby@debian.org>
+Date: Sat, 15 Dec 2018 23:05:52 +0100
+Subject: [PATCH] Fix a test_mozzip_compressed_files test failure under Alpine
+ Linux. (Closes: #916353, reproducible-builds/diffoscope#8)
+
+---
+ tests/comparators/test_zip.py | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/tests/comparators/test_zip.py b/tests/comparators/test_zip.py
+index 413ffd3..ab55429 100644
+--- a/tests/comparators/test_zip.py
++++ b/tests/comparators/test_zip.py
+@@ -105,10 +105,10 @@ def test_mozzip_metadata(mozzip_differences, mozzip1, mozzip2):
+
+ @skip_unless_tools_exist('zipinfo')
+ def test_mozzip_compressed_files(mozzip_differences):
+- assert mozzip_differences[1].source1 == 'dir/text'
+- assert mozzip_differences[1].source2 == 'dir/text'
++ assert mozzip_differences[-1].source1 == 'dir/text'
++ assert mozzip_differences[-1].source2 == 'dir/text'
+ expected_diff = get_data('text_ascii_expected_diff')
+- assert mozzip_differences[1].unified_diff == expected_diff
++ assert mozzip_differences[-1].unified_diff == expected_diff
+
+
+ @skip_unless_tools_exist('zipinfo')
+--
+2.19.2
+