aboutsummaryrefslogtreecommitdiffstats
path: root/testing/doas/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-12-19 09:40:47 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-12-19 09:40:47 +0000
commit81ee4579ec5528a9ed30f62ea5384f443342597c (patch)
tree807d7daf79c4c3fc3cf37159b6c069e79a419f60 /testing/doas/APKBUILD
parent4aa3458d58c852f85db7e7da65fed35091ae5ec3 (diff)
downloadaports-81ee4579ec5528a9ed30f62ea5384f443342597c.tar.bz2
aports-81ee4579ec5528a9ed30f62ea5384f443342597c.tar.xz
testing/doas: add minimal check and minor cleanup
Diffstat (limited to 'testing/doas/APKBUILD')
-rw-r--r--testing/doas/APKBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/testing/doas/APKBUILD b/testing/doas/APKBUILD
index 844afc568e..41344d16f4 100644
--- a/testing/doas/APKBUILD
+++ b/testing/doas/APKBUILD
@@ -9,25 +9,31 @@ license="BSD"
makedepends="bison"
subpackages="$pkgname-doc"
source="
- $pkgname-$pkgver.tar.gz::https://github.com/Duncaen/OpenDoas/archive/v6.0.tar.gz
+ $pkgname-$pkgver.tar.gz::https://github.com/Duncaen/OpenDoas/archive/v$pkgver.tar.gz
doas.conf
"
builddir="$srcdir/OpenDoas-$pkgver"
-options="$options !check suid"
+options="$options suid"
build() {
cd "$builddir"
- ./configure \
- --prefix=/usr \
- --enable-static \
- --without-pam || return 1
- make
+ ./configure \
+ --prefix=/usr \
+ --enable-static \
+ --without-pam
+ make
+}
+
+check() {
+ cd "$builddir"
+ # doas -v returns 1
+ ./doas -v || test $? = 1
}
package() {
cd "$builddir"
- make install DESTDIR="$pkgdir"
- install -Dm440 "$srcdir"/doas.conf "$pkgdir"/etc/doas.conf
+ make install DESTDIR="$pkgdir"
+ install -Dm440 "$srcdir"/doas.conf "$pkgdir"/etc/doas.conf
}
sha512sums="2bf5e00895a45d87785e7a494a1506844afd843ef5375e0b0e3795ebc24712bb941c6feeb87e426e41a240d40aca9b4c099f77220745bb7142a7a4b303441f60 doas-6.0.tar.gz