aboutsummaryrefslogtreecommitdiffstats
path: root/testing/dolphin-plugins
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-06-26 00:57:44 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-25 20:26:23 -0300
commitb80b2072235e078b25a7f484c582ed4437bc1c08 (patch)
tree6265b1646354b10137a68eb8791962021000c40e /testing/dolphin-plugins
parenta1157e89685cb187d3bcff57fc5340a3e70b5873 (diff)
downloadaports-b80b2072235e078b25a7f484c582ed4437bc1c08.tar.bz2
aports-b80b2072235e078b25a7f484c582ed4437bc1c08.tar.xz
testing/dolphin-plugins: new aport
Diffstat (limited to 'testing/dolphin-plugins')
-rw-r--r--testing/dolphin-plugins/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/dolphin-plugins/APKBUILD b/testing/dolphin-plugins/APKBUILD
new file mode 100644
index 0000000000..ede7a03b9b
--- /dev/null
+++ b/testing/dolphin-plugins/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=dolphin-plugins
+pkgver=19.04.2
+pkgrel=0
+arch="all"
+url="https://www.kde.org/applications/system/dolphin/"
+pkgdesc="Extra Dolphin plugins"
+license="GPL-2.0-or-later"
+makedepends="extra-cmake-modules qt5-qtbase-dev kxmlgui-dev ki18n-dev kio-dev ktextwidgets-dev ktexteditor-dev dolphin-dev"
+source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-lang"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="2e1be6581a4d484daa0f1361df1fd6599423daab11522bc6665dcd682bd8b6da5aa732f28cdabc4fae76bf94216124c3c97ed3d3530a456643da5338fca4b815 dolphin-plugins-19.04.2.tar.xz"