aboutsummaryrefslogtreecommitdiffstats
path: root/testing/duktape
diff options
context:
space:
mode:
authorCory Sanin <corysanin@outlook.com>2020-05-04 07:46:12 +0000
committerRasmus Thomsen <oss@cogitri.dev>2020-05-04 07:46:12 +0000
commit5606ecff5f407d9589e0bd7cbc896e9280ea9879 (patch)
tree379190f3afe3ff9c919015a3a0e134075be5e656 /testing/duktape
parenta8009ff6cfef1e9da0ce11eda5a1d423b62abd39 (diff)
downloadaports-5606ecff5f407d9589e0bd7cbc896e9280ea9879.tar.bz2
aports-5606ecff5f407d9589e0bd7cbc896e9280ea9879.tar.xz
testing/duktape: new aport
Diffstat (limited to 'testing/duktape')
-rw-r--r--testing/duktape/APKBUILD31
-rw-r--r--testing/duktape/duktape.pc10
2 files changed, 41 insertions, 0 deletions
diff --git a/testing/duktape/APKBUILD b/testing/duktape/APKBUILD
new file mode 100644
index 0000000000..c85dc51ab2
--- /dev/null
+++ b/testing/duktape/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Cory Sanin <corysanin@outlook.com>
+# Maintainer: Cory Sanin <corysanin@outlook.com>
+pkgname=duktape
+pkgver=2.5.0
+pkgrel=0
+pkgdesc="Embeddable Javascript engine with a focus on portability and compact footprint"
+url="https://duktape.org"
+arch="all"
+license="MIT"
+options="!check" # no tests in release archive
+subpackages="$pkgname-dev"
+source="https://duktape.org/duktape-$pkgver.tar.xz
+ $pkgname.pc
+ "
+
+build() {
+ make -f ./Makefile.sharedlibrary
+}
+
+check() {
+ make check # update if tests are added
+}
+
+package() {
+ make -f ./Makefile.sharedlibrary install INSTALL_PREFIX="$pkgdir/usr"
+ mkdir -p "$pkgdir/usr/lib/pkgconfig/"
+ sed "s/@VERSION@/$pkgver/" "$srcdir/$pkgname.pc" > "$pkgdir/usr/lib/pkgconfig/$pkgname.pc"
+}
+
+sha512sums="230e298a91cb48407d7c2a4b7c85cf9d53151d550e2fd7ba6cb8f9115682abce295fb78a3c3cd22b4812ce86944dd6d28c2b25c3845668a17232e3a08ea63837 duktape-2.5.0.tar.xz
+f7dc8853602233d67b69aff0ae32e9ed4c4a4888edfd27729174e240eca57a8f93a8b9db50e851091bed9cbed8d0028203a925c8424ea0c6f81a1dc046b9297d duktape.pc"
diff --git a/testing/duktape/duktape.pc b/testing/duktape/duktape.pc
new file mode 100644
index 0000000000..b7f115cfbe
--- /dev/null
+++ b/testing/duktape/duktape.pc
@@ -0,0 +1,10 @@
+prefix=/usr
+exec_prefix=${prefix}
+libdir=${exec_prefix}/lib
+includedir=${prefix}/include
+
+Name: duktape
+Description: Embeddable Javascript engine with a focus on portability and compact footprint
+Version: @VERSION@
+Libs: -L${libdir} -lduktape
+Cflags: -I${includedir} \ No newline at end of file