aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ecasound
diff options
context:
space:
mode:
authorJean-Louis Fuchs <ganwell@fangorn.ch>2017-04-10 16:58:28 +0200
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-04-13 07:45:27 +0000
commitad747915656fc4ed2f0835086036f0c9b9b86157 (patch)
tree86bcedd196007af75df9b4429d19d7baf0fff200 /testing/ecasound
parentaf4d856ac5196a7008933e4b176bf620c90ecdfa (diff)
downloadaports-ad747915656fc4ed2f0835086036f0c9b9b86157.tar.bz2
aports-ad747915656fc4ed2f0835086036f0c9b9b86157.tar.xz
testing/ecasound: Move from unmaintained and modernize
* Upgrade to 2.9.1 * Add check * Remove returns * Cleanup dependencies
Diffstat (limited to 'testing/ecasound')
-rw-r--r--testing/ecasound/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/ecasound/APKBUILD b/testing/ecasound/APKBUILD
new file mode 100644
index 0000000000..b25d4b2c18
--- /dev/null
+++ b/testing/ecasound/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
+pkgname=ecasound
+pkgver=2.9.1
+pkgrel=0
+pkgdesc="Textmode multitrack audio processing"
+url="https://ecasound.seul.org/ecasound/"
+arch="all"
+license="GPL2+"
+makedepends="alsa-lib-dev readline-dev ncurses-dev
+ mpg123-dev lame-dev libsndfile-dev libsamplerate-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://ecasound.seul.org/download/ecasound-$pkgver.tar.gz"
+builddir="$srcdir"/ecasound-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+md5sums="13c7be1e4eddc0bbf3792dc17777e465 ecasound-2.9.1.tar.gz"
+sha256sums="39fce8becd84d80620fa3de31fb5223b2b7d4648d36c9c337d3739c2fad0dcf3 ecasound-2.9.1.tar.gz"
+sha512sums="b91fd68cb4809fdf62b25323fbf52c9bb7de6663287d5aa2576cc4fb28e322850b7020df2718ed6087f5d9f5f96692a476287378ea65853d01834523e8eb7033 ecasound-2.9.1.tar.gz"