aboutsummaryrefslogtreecommitdiffstats
path: root/testing/efibootmgr/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2017-10-11 11:26:00 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2017-10-11 11:26:05 +0200
commite8b86a6dbbfc5c2a8ad667de6285c7c7b3ffbb9d (patch)
tree38c33f174b541428a6cad537d8fbfb113b971c08 /testing/efibootmgr/APKBUILD
parentf31278a38b0ac4700b23649cd5e1d5647b7a2343 (diff)
downloadaports-e8b86a6dbbfc5c2a8ad667de6285c7c7b3ffbb9d.tar.bz2
aports-e8b86a6dbbfc5c2a8ad667de6285c7c7b3ffbb9d.tar.xz
testing/efibootmgr: new aport
Diffstat (limited to 'testing/efibootmgr/APKBUILD')
-rw-r--r--testing/efibootmgr/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/efibootmgr/APKBUILD b/testing/efibootmgr/APKBUILD
new file mode 100644
index 0000000000..e34359aabc
--- /dev/null
+++ b/testing/efibootmgr/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=efibootmgr
+pkgver=15
+pkgrel=0
+pkgdesc="Linux user-space application to modify the Intel Extensible Firmware Interface"
+url="https://github.com/rhboot/efibootmgr"
+arch="x86_64 armhf aarch64"
+license="GPL-2.0"
+depends=""
+makedepends="efivar-dev linux-headers popt-dev gettext-dev"
+install=""
+subpackages="$pkgname-doc"
+source="https://github.com/rhboot/efibootmgr/releases/download/$pkgver/efibootmgr-$pkgver.tar.bz2
+ musl-gettext.patch"
+builddir="$srcdir/efibootmgr-$pkgver"
+
+build() {
+ cd "$builddir"
+ PCDIR=/usr/lib/pkgconfig EFIDIR="/boot/efi" make
+}
+
+package() {
+ cd "$builddir"
+ EFIDIR="/boot/efi" make DESTDIR="$pkgdir" install
+}
+
+check() {
+ "$builddir"/src/efibootdump --help > /dev/null
+ "$builddir"/src/efibootmgr --help > /dev/null
+}
+
+sha512sums="d9d9eef14d373d5da88141e8105f754fea4c039755ed0a0cb9b3c9c2bb285733ad930fd912df42075fe2cf750585699307b067f594d8e65269b3b8a5a00b1cd1 efibootmgr-15.tar.bz2
+3ed49c6d267e6f14bf43207fecb55ebc984f6fbd15d77cd1b8f466c8d0a4c3ab9bb276e8ed183b5ab0129fde5c06ffcd0450ffb7dad0edfa18b4c472e481373b musl-gettext.patch"