aboutsummaryrefslogtreecommitdiffstats
path: root/testing/efibootmgr
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-03-01 07:10:04 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-03-01 07:10:04 +0000
commitdc018d3d52e208ba797117cfb48fbb212208b8db (patch)
tree4bbfb59d761eca241437d3a60e5da6118512311d /testing/efibootmgr
parentfcef7207e352fda6a83e6f48764512a70fa48616 (diff)
downloadaports-dc018d3d52e208ba797117cfb48fbb212208b8db.tar.bz2
aports-dc018d3d52e208ba797117cfb48fbb212208b8db.tar.xz
testing/efibootmgr: fix build against new efivar
Diffstat (limited to 'testing/efibootmgr')
-rw-r--r--testing/efibootmgr/APKBUILD6
-rw-r--r--testing/efibootmgr/efivar.patch14
2 files changed, 18 insertions, 2 deletions
diff --git a/testing/efibootmgr/APKBUILD b/testing/efibootmgr/APKBUILD
index 4937d1cf8c..9fc3ec4be4 100644
--- a/testing/efibootmgr/APKBUILD
+++ b/testing/efibootmgr/APKBUILD
@@ -12,7 +12,8 @@ makedepends="efivar-dev linux-headers popt-dev gettext-dev"
install=""
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/rhboot/$pkgname/archive/$pkgver.tar.gz
- musl-gettext.patch"
+ musl-gettext.patch
+ efivar.patch"
builddir="$srcdir/efibootmgr-$pkgver"
build() {
@@ -31,4 +32,5 @@ check() {
}
sha512sums="10c7ad9a79f23dcd4708dc4f42701196af7aa11f5e9a6468ea51f7013d4caeba6c92527ba1304f6e3b2ef3b51b3b69ea1a30f81bb099a8aea49eeb30eb631e1d efibootmgr-17.tar.gz
-3ed49c6d267e6f14bf43207fecb55ebc984f6fbd15d77cd1b8f466c8d0a4c3ab9bb276e8ed183b5ab0129fde5c06ffcd0450ffb7dad0edfa18b4c472e481373b musl-gettext.patch"
+3ed49c6d267e6f14bf43207fecb55ebc984f6fbd15d77cd1b8f466c8d0a4c3ab9bb276e8ed183b5ab0129fde5c06ffcd0450ffb7dad0edfa18b4c472e481373b musl-gettext.patch
+a8f4b37e9c0c55a3b2d20f733606653add0219066b9a46b0878885023480747936ad015a52363ceece481ae4d8b702aaa710d9fde2334aae48f97f650416e129 efivar.patch"
diff --git a/testing/efibootmgr/efivar.patch b/testing/efibootmgr/efivar.patch
new file mode 100644
index 0000000000..614195f3c9
--- /dev/null
+++ b/testing/efibootmgr/efivar.patch
@@ -0,0 +1,14 @@
+diff --git a/src/efibootmgr.c b/src/efibootmgr.c
+index de38f01..4e1a680 100644
+--- a/src/efibootmgr.c
++++ b/src/efibootmgr.c
+@@ -1536,9 +1536,6 @@ parse_opts(int argc, char **argv)
+ "invalid numeric value %s\n",
+ optarg);
+ }
+- /* XXX efivar-36 accidentally doesn't have a public
+- * header for this */
+- extern int efi_set_verbose(int verbosity, FILE *errlog);
+ efi_set_verbose(opts.verbose - 2, stderr);
+ break;
+ case 'V':