aboutsummaryrefslogtreecommitdiffstats
path: root/testing/elvish
diff options
context:
space:
mode:
authorDaniel Isaksen <d@duniel.no>2017-10-01 21:59:26 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-12-10 11:31:17 +0000
commit6d47517c9c44fb63942c9df94b3c9ad13d87b2fc (patch)
tree79a71b067ab1574f36765b49589dadcce5d5d76f /testing/elvish
parent078fc1dc3ff6837411ce0b79c41cc0f60acb1c58 (diff)
downloadaports-6d47517c9c44fb63942c9df94b3c9ad13d87b2fc.tar.bz2
aports-6d47517c9c44fb63942c9df94b3c9ad13d87b2fc.tar.xz
testing/elvish: new aport
Diffstat (limited to 'testing/elvish')
-rw-r--r--testing/elvish/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/elvish/APKBUILD b/testing/elvish/APKBUILD
new file mode 100644
index 0000000000..9096d30852
--- /dev/null
+++ b/testing/elvish/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Daniel Isaksen <d@duniel.no>
+pkgname=elvish
+pkgver=0.12
+pkgrel=0
+pkgdesc="A friendly and expressive shell for Linux, macOS and BSDs"
+url="https://elvish.io/"
+arch="all"
+license="BSD-2-Clause"
+depends=""
+makedepends="go"
+options="!check"
+source="$pkgname-$pkgver.tar.gz::https://github.com/elves/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/src/github.com/elves/$pkgname"
+
+prepare() {
+ mkdir -p ${builddir%/*}
+ mv "$srcdir"/$pkgname-$pkgver "$builddir"/
+ default_prepare
+}
+
+build() {
+ cd "$builddir"
+ export GOPATH="$srcdir"
+ go build -o bin/$pkgname
+}
+
+package() {
+ install -Dm755 "$builddir"/bin/elvish "$pkgdir"/usr/bin
+}
+
+sha512sums="21e31caf997d23412c8a9d2ed9b3bcfb60763e17af4ec4ee09db9027e10ebab4fd331a4be7d5b60ba0aa5ff1a7c5709762e5375f61cac0cbf18bf3d4e73d46fa elvish-0.12.tar.gz"