aboutsummaryrefslogtreecommitdiffstats
path: root/testing/enchant2
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-05-02 00:02:12 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-10 19:39:08 +0000
commit01ce78041afc38e4e765cfb232ec9bb22f87719f (patch)
tree9406464e4114d603c120519dd086598d518a4eaa /testing/enchant2
parentb91ce77f1254234e43aec2235c861f248b670b5c (diff)
downloadaports-01ce78041afc38e4e765cfb232ec9bb22f87719f.tar.bz2
aports-01ce78041afc38e4e765cfb232ec9bb22f87719f.tar.xz
testing/enchant2: new aport
Diffstat (limited to 'testing/enchant2')
-rw-r--r--testing/enchant2/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/enchant2/APKBUILD b/testing/enchant2/APKBUILD
new file mode 100644
index 0000000000..e04ab351a8
--- /dev/null
+++ b/testing/enchant2/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=enchant2
+pkgver=2.2.3
+pkgrel=0
+pkgdesc="A wrapper library for generic spell checking (v2)"
+url="https://abiword.github.io/enchant/"
+arch="all"
+license="LGPL-2.1-or-later"
+subpackages="$pkgname-dev $pkgname-doc"
+makedepends="aspell-dev glib-dev dbus-glib-dev hunspell-dev gettext-dev file
+ bash aspell-dev"
+options="!check" # needs unpackaged unittest-cpp
+source="https://github.com/AbiWord/enchant/releases/download/v${pkgver}/enchant-${pkgver}.tar.gz"
+builddir="$srcdir/enchant-$pkgver"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --disable-static
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" pkgdatadir=/usr/share/enchant-2 install
+}
+
+sha512sums="abde9d6fec25edff694570455fd4c6e8e2e2c41a6b133bbb31a344761137a354cc1c655e53374cf712bf311c3732dc721e9ffd2dc933d78ec8ccf224350635d6 enchant-2.2.3.tar.gz"