aboutsummaryrefslogtreecommitdiffstats
path: root/testing/enet
diff options
context:
space:
mode:
authorAlexander Willing <alexander.willing@spiegel.de>2020-03-02 16:55:42 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-03-02 17:51:17 +0100
commit7e273ff23c1aefe5fd8290cafd6207779c21dcbf (patch)
treeab709a423d845d622353a032ebaa9480319c69e1 /testing/enet
parentc8dfdcc85eb1dc16bad24a68c5b6a66d9b009249 (diff)
downloadaports-7e273ff23c1aefe5fd8290cafd6207779c21dcbf.tar.bz2
aports-7e273ff23c1aefe5fd8290cafd6207779c21dcbf.tar.xz
testing/enet: move from unmaintained
Diffstat (limited to 'testing/enet')
-rw-r--r--testing/enet/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/enet/APKBUILD b/testing/enet/APKBUILD
new file mode 100644
index 0000000000..b616a51075
--- /dev/null
+++ b/testing/enet/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: Daniel Sabogal <dsabogalcc@gmail.com>
+# Maintainer: Alexander Willing <willing.alexander@googlemail.com>
+pkgname=enet
+pkgver=1.3.14
+pkgrel=0
+pkgdesc="Reliable UDP networking library"
+options="!check" # No testsuite
+url="http://enet.bespin.org"
+arch="all"
+license="MIT"
+subpackages="$pkgname-dev"
+source="http://enet.bespin.org/download/$pkgname-$pkgver.tar.gz"
+
+build() {
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir/" install
+}
+
+sha512sums="56011529c02ef085e57c77b7d6b72e5d0e76159ebf94a9980f50c2c8f7ef85a32a163e65d9414dda810fc2204e71c389745e7725a731371e2847a45bd4e18704 enet-1.3.14.tar.gz"