aboutsummaryrefslogtreecommitdiffstats
path: root/testing/etcd
diff options
context:
space:
mode:
authorEd Robinson <ed.robinson@reevoo.com>2017-03-27 19:41:32 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-04-11 01:31:59 +0200
commitd1d1723b3680cedb29ddd580bc88d2cc9436272f (patch)
tree71cf6573c28efa8cb80808c5c7a5da21c329fa6f /testing/etcd
parentad037349e2b0b41a60917cf5bbbdbd642ab4752b (diff)
downloadaports-d1d1723b3680cedb29ddd580bc88d2cc9436272f.tar.bz2
aports-d1d1723b3680cedb29ddd580bc88d2cc9436272f.tar.xz
testing/etcd: move etcdctl to subpackage
etcdctl can be a useful utility to have without etcd itself, when connecting to a remote cluster, or from within a container. Equaly it might not be needed when installing the server.
Diffstat (limited to 'testing/etcd')
-rw-r--r--testing/etcd/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/testing/etcd/APKBUILD b/testing/etcd/APKBUILD
index 3979adc739..8600d214c4 100644
--- a/testing/etcd/APKBUILD
+++ b/testing/etcd/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=etcd
pkgver=3.1.5
-pkgrel=0
+pkgrel=1
pkgdesc="A highly-available key value store for shared configuration and service discovery"
url="https://github.com/coreos/etcd"
arch="x86_64"
@@ -12,7 +12,7 @@ options="!strip"
install="$pkgname.pre-install"
pkgusers="$pkgname"
pkggroups="$pkgname"
-subpackages="$pkgname-doc"
+subpackages="$pkgname-doc $pkgname-etcdctl"
source="$pkgname-$pkgver.tar.gz::https://github.com/coreos/etcd/archive/v$pkgver.tar.gz
$pkgname.confd
$pkgname.initd"
@@ -35,13 +35,18 @@ package() {
cd "$builddir"
mkdir -p "$pkgdir"/var/lib/$pkgname
chown -R $pkgusers:$pkggroups "$pkgdir"/var/lib/$pkgname
- install -Dm755 bin/etcdctl "$pkgdir"/usr/bin/etcdctl
install -Dm755 bin/etcd "$pkgdir"/usr/bin/etcd
install -Dm755 $srcdir/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
install -Dm755 $srcdir/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
+etcdctl() {
+ pkgname="A command-line client for etcd"
+
+ install -Dm755 "$builddir"/bin/etcdctl "$subpkgdir"/usr/bin/etcdctl
+}
+
sha512sums="6a91be81721179579fbe2b054c23c196aae3c10e3af2ff4e3472e501c7dbbb3dd1adc796d9d2c9f91d46fff7caab45d2cab082a5275c1b90a0f7ded8e67985bb etcd-3.1.5.tar.gz
440c9f23decb318c565a79d376b107dbd2333e72d5d812ec1460732543348737468b3e66e82e06a1afa0f09760c1eb066804a668a24e92a23977758727e049d2 etcd.confd
99271b1ae4a5636ae2332a98d35a5d9e27cac9154d5ede7952b0627caca53ef0b0d8164aa18f53c25e42e969b80e534930c2a3ed0bd0a1fdaec093075016355c etcd.initd"