aboutsummaryrefslogtreecommitdiffstats
path: root/testing/evolution/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-04-17 10:50:47 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-04-17 10:59:05 +0000
commit75dac003d94e47ed243d563fd735871256325405 (patch)
tree15098077ea72726ce37081c5373856ab88f6890b /testing/evolution/APKBUILD
parent731d5b74ea37819053d82f52a95c8966de27df60 (diff)
downloadaports-75dac003d94e47ed243d563fd735871256325405.tar.bz2
aports-75dac003d94e47ed243d563fd735871256325405.tar.xz
testing/evolution: upgrade to 3.24.1
Diffstat (limited to 'testing/evolution/APKBUILD')
-rw-r--r--testing/evolution/APKBUILD39
1 files changed, 21 insertions, 18 deletions
diff --git a/testing/evolution/APKBUILD b/testing/evolution/APKBUILD
index 46ffe1ac1c..b23e06d607 100644
--- a/testing/evolution/APKBUILD
+++ b/testing/evolution/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=evolution
-pkgver=3.22.4
-pkgrel=1
+pkgver=3.24.1
+pkgrel=0
pkgdesc="evolution mail client"
url="http://projects.gnome.org/evolution"
# limited by webkit2gtk
@@ -13,7 +13,7 @@ depends_dev="itstool libxml2-dev gcr-dev enchant-dev libcanberra-dev
libgweather-dev openldap-dev libnotify-dev"
makedepends="$depends_dev gperf flex bison libxml2-utils glib-dev
webkit2gtk-dev gtkspell3-dev evolution-data-server-dev glib-dev
- gtk+3.0-dev nss-dev"
+ gtk+3.0-dev nss-dev cmake gnu-libiconv-dev"
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="http://ftp.gnome.org/pub/gnome/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.xz
@@ -22,25 +22,28 @@ source="http://ftp.gnome.org/pub/gnome/sources/${pkgname}/${pkgver%.*}/${pkgname
builddir="${srcdir}/${pkgname}-${pkgver}"
build() {
- cd "$builddir"
- export ac_cv_libiconv_utf8=yes
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --disable-gnome-desktop \
- --disable-autoar \
- --disable-libcryptui \
- --disable-schemas-compile \
- --disable-pst-import \
- --with-openldap \
- --enable-nss=yes \
- --enable-smime=yes \
- || return 1
+ mkdir -p "$builddir"/build
+ cd "$builddir"/build
+ CFLAGS="$CFLAGS -I/usr/include/gnu-libiconv" \
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DENABLE_GNOME_DESKTOP=OFF \
+ -DENABLE_AUTOAR=OFF \
+ -DENABLE_LIBCRYPTUI=OFF \
+ -DENABLE_YTNEF=OFF \
+ -DENABLE_PST_IMPORT=OFF \
+ -DENABLE_NSS=ON \
+ -DENABLE_SMIME=ON \
+ .. \
+ || return 1
make || return 1
}
package() {
- cd "$builddir"
+ cd "$builddir"/build
make DESTDIR="$pkgdir" install || return 1
}
-sha512sums="dd73a11d4d7903be6a99bf0d937f5a217a26f0dffb9dc0cea2ca81142d5783c42f889a8b913d565678e9f55b7f2f2a1d42f06c30e3cb004926c19f44dae3b70f evolution-3.22.4.tar.xz"
+sha512sums="ad88f2dedf529eec38461887d27544968e22d0a56d3f7fe4b547b1436c462c2175a556c6664c287dd3765e9b9499427acd846bee242a8a85b3049a9ba3b90bba evolution-3.24.1.tar.xz"