aboutsummaryrefslogtreecommitdiffstats
path: root/testing/fcount
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-04-22 00:16:44 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-22 10:53:10 +0000
commit6f53e473b58ea8419c1594ec8303c859c9d7e1dd (patch)
treeee7c44959690d52d9df07aaa178f5ca36f2a9132 /testing/fcount
parent036c1947acbf6b30d8f6473b51e00dcce548cea4 (diff)
downloadaports-6f53e473b58ea8419c1594ec8303c859c9d7e1dd.tar.bz2
aports-6f53e473b58ea8419c1594ec8303c859c9d7e1dd.tar.xz
testing/fcount: new aport
Diffstat (limited to 'testing/fcount')
-rw-r--r--testing/fcount/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/fcount/APKBUILD b/testing/fcount/APKBUILD
new file mode 100644
index 0000000000..68b0d155d4
--- /dev/null
+++ b/testing/fcount/APKBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=fcount
+pkgver=0.3
+pkgrel=0
+pkgdesc="Counts the number of files within a directory"
+url="http://git.z3bra.org/fcount/log.html"
+arch="all"
+license="WTFPL"
+source="http://dl.z3bra.org/releases/${pkgname}-${pkgver}.tar.bz2"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ make
+}
+
+check() {
+ ./fcount
+}
+
+package() {
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}
+
+sha512sums="0f9e400d9e9e8f9442dcee74f606c56c7b4be48dd3491bf7a78e344b868be96da964d41333cd4b65c66a75580cd414feb0fc11459fab306e68b7c403586e5289 fcount-0.3.tar.bz2"