aboutsummaryrefslogtreecommitdiffstats
path: root/testing/fd
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-04-23 14:31:10 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-23 19:47:12 +0000
commit6ecac04c0a931fa530563c3e0f6662c527377c73 (patch)
tree22e03ef8e4ed7fc118acb398ead811eef8d7d928 /testing/fd
parent3c74472efadae3f1355e5d24714eac66256619a6 (diff)
downloadaports-6ecac04c0a931fa530563c3e0f6662c527377c73.tar.bz2
aports-6ecac04c0a931fa530563c3e0f6662c527377c73.tar.xz
testing/fd: new aport
Diffstat (limited to 'testing/fd')
-rw-r--r--testing/fd/APKBUILD59
1 files changed, 59 insertions, 0 deletions
diff --git a/testing/fd/APKBUILD b/testing/fd/APKBUILD
new file mode 100644
index 0000000000..6143a04c05
--- /dev/null
+++ b/testing/fd/APKBUILD
@@ -0,0 +1,59 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=fd
+pkgver=7.3.0
+pkgrel=0
+pkgdesc="Simple, fast, user-friendly alternative to find"
+url="https://github.com/sharkdp/fd"
+arch="x86_64" # Cargo
+license="MIT Apache-2.0"
+makedepends="cargo"
+subpackages="
+ $pkgname-doc
+ $pkgname-bash-completion:bashcomp:noarch
+ $pkgname-zsh-compltion:zshcomp:noarch
+ $pkgname-fish-completion:fishcomp:noarch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/sharkdp/fd/archive/v${pkgver}.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cargo build --release
+}
+
+check() {
+ cargo test --release
+}
+
+package() {
+ cargo install --path . --root="$pkgdir"/usr
+ rm "$pkgdir"/usr/.crates.toml
+ install -Dm644 doc/fd.1 "$pkgdir"/usr/share/man/man1/fd.1
+}
+
+bashcomp() {
+ depends=""
+ pkgdesc="Bash completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+
+ install -Dm644 "$builddir"/target/release/build/fd-find-*/out/fd.bash \
+ "$subpkgdir"/usr/share/bash-completion/completions/$pkgname
+}
+
+zshcomp() {
+ depends=""
+ pkgdesc="Zsh completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel zsh"
+
+ install -Dm644 "$builddir"/target/release/build/fd-find-*/out/_fd \
+ "$subpkgdir"/usr/share/zsh/site-functions/_$pkgname
+}
+
+fishcomp() {
+ depends=""
+ pkgdesc="Fish completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel fish"
+
+ install -Dm644 "$builddir"/target/release/build/fd-find-*/out/fd.fish \
+ "$subpkgdir"/usr/share/fish/completions/fd.fish
+}
+sha512sums="48a7a9b41463070d26c76018909c527c4a33efd6b6c7e68184ff1e477bb87483ce7ed49c214893a01de0c57579026fe0616b989d169eed001529d377028371d5 fd-7.3.0.tar.gz"