aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ffcall
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-30 02:40:48 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-30 04:31:48 -0300
commit470e2801ec43749489dad8377d3e07a938330f71 (patch)
treeac045c3f123b13e4b627a2db387b4ed2615a71b5 /testing/ffcall
parente7a6c6a4ada7df3acf1ad057357840f8763e0ad3 (diff)
downloadaports-470e2801ec43749489dad8377d3e07a938330f71.tar.bz2
aports-470e2801ec43749489dad8377d3e07a938330f71.tar.xz
testing/ffcall: upgrade to 2.2
Diffstat (limited to 'testing/ffcall')
-rw-r--r--testing/ffcall/APKBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/testing/ffcall/APKBUILD b/testing/ffcall/APKBUILD
index ef2a194aa4..218663cb26 100644
--- a/testing/ffcall/APKBUILD
+++ b/testing/ffcall/APKBUILD
@@ -1,23 +1,19 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer:
pkgname=ffcall
-pkgver=2.1
-pkgrel=1
+pkgver=2.2
+pkgrel=0
pkgdesc="C library for implementing foreign function calls in embedded interpreters"
url="https://www.gnu.org/software/libffcall"
arch="all !x86 !armhf !armv7"
license="GPL-2.0-or-later"
-depends=""
-depends_dev=""
makedepends="$depends_dev"
-install=""
subpackages="$pkgname-doc"
source="https://ftp.gnu.org/gnu/libffcall/libffcall-$pkgver.tar.gz"
builddir="$srcdir"/libffcall-$pkgver
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -25,18 +21,21 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --localstatedir=/var
+ --localstatedir=/var \
+ --disable-static
make -j1
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" htmldir=/usr/share/doc/ffcall install
+
+ # One of the static libraries is not disabled by --disable-static
+ # while all others are, so remove it here
+ rm -f "$pkgdir"/usr/lib/*.a
}
-sha512sums="da73375fb45b7d764c06437a517c2a90abf7d5de6afe0a8ca19e6dfafd2a8c7107e39d230ecbc8edfdd5926b16a0c13b7bb9319287047c47de1241b2f6ae805e libffcall-2.1.tar.gz"
+sha512sums="b9d3ca4c67ab92915a8183d850153e585dcb58ceb2199a104426a7aae363d37017b1226440acd18a2db0cc207e044f71e932857189964261e8eaa6de5cef1731 libffcall-2.2.tar.gz"