aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ffsend
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2020-02-08 21:01:12 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2020-02-14 21:37:33 +0000
commit3b688d6457197778ccafda14cdd203d1362cca03 (patch)
tree4020fac284055b624cfea06e5b9065337b32f49d /testing/ffsend
parent26e1e59c6cfb1cfe95d5f5110808006462c611d1 (diff)
downloadaports-3b688d6457197778ccafda14cdd203d1362cca03.tar.bz2
aports-3b688d6457197778ccafda14cdd203d1362cca03.tar.xz
testing/various: enable stackprotector
On x86, the stack protector was disabled by addinsg `-fno-stack-protector` to CFLAGS. This was due to rust not passing `-lssp_nonshared` to the linker, causing build errors while linking. Rust has been patched to fix this issue, so now we can enable stack protection again.
Diffstat (limited to 'testing/ffsend')
-rw-r--r--testing/ffsend/APKBUILD8
1 files changed, 1 insertions, 7 deletions
diff --git a/testing/ffsend/APKBUILD b/testing/ffsend/APKBUILD
index 581ba4b37a..ec1260c483 100644
--- a/testing/ffsend/APKBUILD
+++ b/testing/ffsend/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=ffsend
pkgver=0.2.58
-pkgrel=0
+pkgrel=1
pkgdesc="A fully featured Firefox Send client"
url="https://gitlab.com/timvisee/ffsend"
arch="x86_64 x86 armhf armv7 aarch64 ppc64le" # limited by cargo
@@ -16,12 +16,6 @@ subpackages="
source="https://gitlab.com/timvisee/ffsend/-/archive/v$pkgver/ffsend-v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-v$pkgver"
-case "$CARCH" in
- x86)
- export CFLAGS="$CFLAGS -fno-stack-protector"
- ;;
-esac
-
build() {
cargo build --release
}