aboutsummaryrefslogtreecommitdiffstats
path: root/testing/filebeat
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-12 08:07:23 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-11-12 10:53:24 -0300
commit04484994081ed9b1ca62c373360950769bb810cd (patch)
tree522eeb9ab76058dfe5bc2fdd0df97cf253ca9626 /testing/filebeat
parent1ed11fa0845152805c9750766776059d2c05f9b4 (diff)
downloadaports-04484994081ed9b1ca62c373360950769bb810cd.tar.bz2
aports-04484994081ed9b1ca62c373360950769bb810cd.tar.xz
testing/filebeat: upgrade to 7.4.2
Diffstat (limited to 'testing/filebeat')
-rw-r--r--testing/filebeat/APKBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/testing/filebeat/APKBUILD b/testing/filebeat/APKBUILD
index bf81976d8f..87bcabe4cb 100644
--- a/testing/filebeat/APKBUILD
+++ b/testing/filebeat/APKBUILD
@@ -1,19 +1,17 @@
# Contributor: Ramanathan Sivagurunathan <ramzthecoder@gmail.com>
# Maintainer: Ramanathan Sivagurunathan <ramzthecoder@gmail.com>
pkgname=filebeat
-pkgver=6.4.2
-pkgrel=1
+pkgver=7.4.2
+pkgrel=0
pkgdesc="Lightweight Shipper for Logs"
pkgusers="root"
url="https://www.elastic.co/products/beats"
arch="all !armhf !armv7 !aarch64"
license="Apache-2.0"
-depends=""
makedepends="go"
-install=""
subpackages="$pkgname-openrc"
options="!check" # No test suite
-source="beats-${pkgver}.tar.gz::https://github.com/elastic/beats/archive/v$pkgver.tar.gz
+source="beats-$pkgver.tar.gz::https://github.com/elastic/beats/archive/v$pkgver.tar.gz
filebeat.initd
filebeat.confd
filebeat.yml
@@ -22,24 +20,22 @@ builddir="$srcdir/src/github.com/elastic/beats/$pkgname"
prepare() {
mkdir -p "$srcdir/src/github.com/elastic/"
- mv "$srcdir/beats-${pkgver}" "$srcdir/src/github.com/elastic/beats"
+ mv "$srcdir/beats-$pkgver" "$srcdir/src/github.com/elastic/beats"
default_prepare
}
build() {
- cd "$builddir"
GOPATH="$srcdir" go build -v
}
package() {
- cd "$builddir"
install -Dm755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
install -Dm644 "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
install -Dm644 "$srcdir/filebeat.yml" "$pkgdir/etc/$pkgname/filebeat.yml"
install -Dm755 "$builddir/filebeat" "$pkgdir/usr/bin/filebeat"
}
-sha512sums="97282cd7ab992c4c5a46f0d46b496036ab642566df2e499a705cf6fa4da9a5fbfa5e6b38c79b1670bdcdd3f7d2bdd1fcf23cf7769cc821779c9c63515d090e45 beats-6.4.2.tar.gz
+sha512sums="cd6437fb0fc46cf4bd2630cc6b6a465851f7de693e6679d8a3e96f4577e68db64a7d9353281816ab3e6e7409d8775a5172580f1b05014721ce740e184a7aa179 beats-7.4.2.tar.gz
ea49bc4da6f66e01ad2b563d9179a992c6dc07410c8ad107f7c5ce65426ee6010871b1cbf9634310765aa5d2da0261eb2aee2c93bbe11de5f0d6d7e903402d15 filebeat.initd
25321037cd036f05186c21c73889e9b2716bbfa30597edcf90a110fca761396f30df20142e025d6175ae6ed743f08c574fa54e8df8577c1bf416bce17bec7170 filebeat.confd
b0d5fa1d37041a4f1383451107abcdab1ce15ed537f702f55756f59c2110445dcddaf7c58f2a0561e18b83e3cab72fceb9d931bae9267f1acd9d35135555d6f7 filebeat.yml"