aboutsummaryrefslogtreecommitdiffstats
path: root/testing/filezilla
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-07-25 12:31:03 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-07-25 12:31:28 +0000
commita5aca505eca343c545ced27e9b6f57b521866669 (patch)
treefdba1611cf7f4e1c1804ca462d4186a77e016f40 /testing/filezilla
parent14853223b9b3dcf19cffccdcc728e7737ca559e7 (diff)
downloadaports-a5aca505eca343c545ced27e9b6f57b521866669.tar.bz2
aports-a5aca505eca343c545ced27e9b6f57b521866669.tar.xz
testing/filezilla: new aport
FTP Client
Diffstat (limited to 'testing/filezilla')
-rw-r--r--testing/filezilla/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/filezilla/APKBUILD b/testing/filezilla/APKBUILD
new file mode 100644
index 0000000000..5709767926
--- /dev/null
+++ b/testing/filezilla/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=filezilla
+pkgver=3.27.0.1
+pkgrel=0
+pkgdesc="FTP Client"
+url="http://filezilla-project.org"
+arch="all"
+license="GPL2"
+makedepends="libfilezilla-dev wxgtk-dev libidn-dev nettle-dev gnutls-dev
+ pugixml-dev xdg-utils gtk+2.0-dev sqlite-dev"
+subpackages="$pkgname-doc $pkgname-lang"
+source="https://downloads.sourceforge.net/project/filezilla/FileZilla_Client/$pkgver/FileZilla_${pkgver}_src.tar.bz2"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --without-dbus
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+sha512sums="011a96c3664af56eee424338502b406b46729d1bbb3453b9d8888b86fa49eb994a29b478805e400290c597ea87decd27373df37f934cd47248f2c6f26a4bb828 FileZilla_3.27.0.1_src.tar.bz2"