aboutsummaryrefslogtreecommitdiffstats
path: root/testing/fio
diff options
context:
space:
mode:
authorwener <wenermail@gmail.com>2018-04-02 01:39:15 +0800
committerHenrik Riomar <henrik.riomar@gmail.com>2019-03-05 17:34:07 +0100
commit44e30565c6754513308989d0ee35cd92ce630f57 (patch)
tree87ea45920a9a3c9aa5a3ef41e64e657d1de2fbb5 /testing/fio
parenta551bde04b190822fcace4d589677aac37613be9 (diff)
downloadaports-44e30565c6754513308989d0ee35cd92ce630f57.tar.bz2
aports-44e30565c6754513308989d0ee35cd92ce630f57.tar.xz
testing/fio: new aport
Diffstat (limited to 'testing/fio')
-rw-r--r--testing/fio/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/fio/APKBUILD b/testing/fio/APKBUILD
new file mode 100644
index 0000000000..1585d3e797
--- /dev/null
+++ b/testing/fio/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: wener <wenermail@gmail.com>
+# Maintainer: wener <wenermail@gmail.com>
+pkgname=fio
+pkgver=3.5
+pkgrel=0
+pkgdesc="Flexible I/O Tester"
+url="https://github.com/axboe/fio"
+arch="all"
+license="GPL-2.0"
+makedepends="linux-headers zlib-dev coreutils py-sphinx"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/axboe/fio/archive/fio-$pkgver.tar.gz"
+builddir="$srcdir/fio-$pkgname-$pkgver"
+options="!check"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+doc() {
+ cd "$builddir"
+ mkdir -p "$subpkgdir/usr"
+ mv "$pkgdir/usr/man" "$subpkgdir/usr"
+}
+
+sha512sums="a31c107d9d1aed244a1e7b54a5768ae0d246f39b419815bf6f94ae4424de1ae569bdae2c4e589435b0d1b44eb7a8b7a670a3c44b7d746b326826325a3f27a909 fio-3.5.tar.gz"