aboutsummaryrefslogtreecommitdiffstats
path: root/testing/fio
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2019-03-05 13:58:46 +0100
committerHenrik Riomar <henrik.riomar@gmail.com>2019-03-05 17:34:07 +0100
commit9f181dd5421201a2f7250a8350bbcaa9da1ccfd0 (patch)
tree4dfa8afeeaf997f50394c741f86e94864e0cf3b6 /testing/fio
parent44e30565c6754513308989d0ee35cd92ce630f57 (diff)
downloadaports-9f181dd5421201a2f7250a8350bbcaa9da1ccfd0.tar.bz2
aports-9f181dd5421201a2f7250a8350bbcaa9da1ccfd0.tar.xz
testing/fio: upgrade to 3.13
* Enable the test suite * Build with numa support * Build with libaio support
Diffstat (limited to 'testing/fio')
-rw-r--r--testing/fio/APKBUILD26
1 files changed, 20 insertions, 6 deletions
diff --git a/testing/fio/APKBUILD b/testing/fio/APKBUILD
index 1585d3e797..877e8ddb70 100644
--- a/testing/fio/APKBUILD
+++ b/testing/fio/APKBUILD
@@ -1,17 +1,24 @@
# Contributor: wener <wenermail@gmail.com>
# Maintainer: wener <wenermail@gmail.com>
pkgname=fio
-pkgver=3.5
+pkgver=3.13
pkgrel=0
pkgdesc="Flexible I/O Tester"
url="https://github.com/axboe/fio"
arch="all"
license="GPL-2.0"
-makedepends="linux-headers zlib-dev coreutils py-sphinx"
+makedepends="linux-headers zlib-dev coreutils py-sphinx libaio-dev"
+case "$CARCH" in
+ arm*)
+ # no numactl-dev for arm
+ ;;
+ *)
+ makedepends="$makedepends numactl-dev"
+ ;;
+esac
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/axboe/fio/archive/fio-$pkgver.tar.gz"
builddir="$srcdir/fio-$pkgname-$pkgver"
-options="!check"
build() {
cd "$builddir"
@@ -19,14 +26,21 @@ build() {
make
}
-package() {
+check() {
cd "$builddir"
- make DESTDIR="$pkgdir" install
+ make test
}
+
+# needed to handle fio-fio-<version> directory name
doc() {
cd "$builddir"
mkdir -p "$subpkgdir/usr"
mv "$pkgdir/usr/man" "$subpkgdir/usr"
}
-sha512sums="a31c107d9d1aed244a1e7b54a5768ae0d246f39b419815bf6f94ae4424de1ae569bdae2c4e589435b0d1b44eb7a8b7a670a3c44b7d746b326826325a3f27a909 fio-3.5.tar.gz"
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="f3ed96bbcd16d326db331542147723f2f2d856241443a59bcd5c7f38b8ff496e16409051d7cf25571b7deb17c2f88bb1acf4199685d932a8883a40d95216a70c fio-3.13.tar.gz"