aboutsummaryrefslogtreecommitdiffstats
path: root/testing/firefox/APKBUILD
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-01-22 00:42:51 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2011-01-22 00:42:51 -0600
commit0e7ddfe93a5f7fe6943b9511c7b0a7976ffc699b (patch)
tree8bbcc9d33d73edd87a84a4509e0370c5b5a1d0b3 /testing/firefox/APKBUILD
parent953e2f632c4193af9350100a0b2640320a20d2ff (diff)
downloadaports-0e7ddfe93a5f7fe6943b9511c7b0a7976ffc699b.tar.bz2
aports-0e7ddfe93a5f7fe6943b9511c7b0a7976ffc699b.tar.xz
testing/firefox: new aport
Diffstat (limited to 'testing/firefox/APKBUILD')
-rw-r--r--testing/firefox/APKBUILD66
1 files changed, 66 insertions, 0 deletions
diff --git a/testing/firefox/APKBUILD b/testing/firefox/APKBUILD
new file mode 100644
index 0000000000..7e8fd52392
--- /dev/null
+++ b/testing/firefox/APKBUILD
@@ -0,0 +1,66 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=firefox
+pkgver=3.6.13
+_xulver=1.9.2.13
+pkgrel=0
+pkgdesc="firefox web browser (unofficial branding)"
+url="http://www.firefox.com"
+arch="all"
+license="GPL LGPL MPL"
+depends="xulrunner"
+makedepends="xulrunner-dev>=${_xulver}
+
+ autoconf2.13
+
+ python
+ zip
+
+ autoconf
+ automake
+ libtool"
+install=""
+subpackages=""
+source="http://releases.mozilla.org/pub/mozilla.org/${pkgname}/releases/${pkgver}/source/${pkgname}-${pkgver}.source.tar.bz2
+ mozconfig
+ firefox-agent.patch
+ firefox-defaults.patch
+ firefox-version.patch"
+
+_xulrunner_version="${_xulver%.*}"
+_builddir="${srcdir}/mozilla-${_xulrunner_version}"
+prepare() {
+ local i
+
+ cd "$_builddir"
+
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+
+ cp "${srcdir}/mozconfig" .mozconfig
+}
+
+build() {
+ cd "$_builddir"
+
+ # mozilla's buildsystem is on drugs, so we just kill our CFLAGS and hope
+ # for the best. --nenolod
+ unset CFLAGS
+ unset CXXFLAGS
+
+ make -j1 -f client.mk build MOZ_MAKE_FLAGS="$MAKEFLAGS" || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="d7c90aed8209beefa74badf02e8eeae1 firefox-3.6.13.source.tar.bz2
+7938f0054456f3767d2427dff137ab34 mozconfig
+f437e94acff8f810991271ef4677d859 firefox-agent.patch
+1807651225b021e043154f8bba715a19 firefox-defaults.patch
+92c11c66dd69b03f214002fededd1fc8 firefox-version.patch"